GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Has this ever happened to anyone

    2003 GMC Yukon with 100,000 has always run like a charm with normal service. Even in the cold winter I could turn the ign. switch to start release and truck would start after turning over 2 or 3 times. The other day in Memphis 95 deg. weather turned ign. switch to start realeased truck turned over 5 or 6 times and no start hit the starter and truck cranked up no problem. Next morning no start after turning over 7 or so times and releasing key it would only diesel for a few seconds. Any Ideas, Thanks

  2. #2

    Default

    this can be many different things. fuel pump, fuel regulator, IAC or any other possibility Battery, cables. you might see if there are any stored codes and or the year the battery was installed.....mike
    Michael Collins
    1993 4X4 Suburban
    many other toys as well

  3. #3

    Default

    i would recommend checking your battery terminals and cables. clean them up nicely and get any corrosion off and retighten down your cables. you may have a lose connection with your fuel pump as well and it may not be coming on.
    PETE
    95 GMC Sierra 2500
    3" Body Lift, 33" Goodyear MTR's
    5.7L 350 TBI Edelbrock SDT Exhaust, Flowtech Headers, K&N Intake
    Sold :(
    1999 Jeep Cherokee, 3" Rustys lift, 33" BFG MT's, locked, armored: Rolled :(
    2000 Jeep Grand Cherokee Limited. K&N Intake, Custom Kolak Exhaust


    Contact this GMTC Moderator for any problems or questions you may have :great:

    Join the GMTC Facebook Group!!! Join Here

  4. #4

    Default

    Have you changed the plugs, fuel and air filters? May be some dirty injectors, you might try a can of Sea Foam.
    Gary

    99 K 1500 Suburban
    78 Silverado Big 10 w/factory 454
    00 S-10 Blazer
    1976 Trans Am
    1980 Honda CB900 Custom

  5. #5

    Default

    It could be a couple different things. It may be starving for fuel, need to change filter, or water in gas. New cap and rotor, and plugs and wires wont hurt anything either.

Similar Threads

  1. Just changed oil, strange thing happened...
    By BrokeEnthusiast in forum General Chevy & GM Tech Questions
    Replies: 22
    Last Post: 03-16-2010, 04:58 PM
  2. th400 dumped tranny fluid all over the highway. What happened?
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 11-03-2009, 11:38 AM
  3. So, what might have happened to my battery?
    By captainstormy in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 02-13-2008, 10:48 AM
  4. what happened??????
    By GM_Guy in forum Chevy Uplander & GM Minivan Forum
    Replies: 11
    Last Post: 08-28-2007, 05:47 PM
  5. What ever happened to the console build?
    By 84fiero123 in forum Announcements & Feedback
    Replies: 8
    Last Post: 08-16-2006, 07:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •