GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 24
  1. #1

    Default 87' S-10 2.5 issue

    hey guys. A buddy of mine just bought a 87 s10 2.5 4 speed with 88k original miles on it. We are having a problem that is stumping the hell out of us. Let me start from the beginning. We went to buy the truck. guy said it was sitting for a while but we started it and it started right up. didnt test drive it far, just around thew block but ran strong. Bought it and started driving it home and after about 15 minuted of driving i did notice it would sputter/ missfire at higher rpm (of course it doesnt have a tach so wasnt sure if it was just hitting limiter but seemed like more of a miss) so as soon as we pull onto the highway it starts cutting out, I tried to give it gas but nothing and as soon as i push the clutch in, it stalls out completely. tried to restart it and it fired up, got 10 feet and it did the same thing again. then it wouldnt re-start again. saw the injector pulsing fuel into the TB so i know it was getting fuel. So we got it towed home. as soon as we got it home it fired up again. We did a basic tune up as the plugs, wires, etc looked original. things we did so far; oil change, plugs, wires, cap, rotor, coil, coolant temp sensor (front one), removed cat (we were thinking it could be clogged). still does the same thing! fires up and runs fine when cold. can run it for about 10-15 minutes till it gets hot it seems, then it will start to missfire at high rpm and shortly after it will just cut out. and wont start and stay running again till it cools off. any ideas?? we are running out of ideas lol

  2. #2

    Default

    Check out the ignition module. Mine did the same thing. The ignition module would fail when it got hot. I've also had the map sensor do that to me on my dodge
    Chuckie!!!


  3. #3

    Default

    Quote Originally Posted by BurbanMan View Post
    Check out the ignition module. Mine did the same thing. The ignition module would fail when it got hot. I've also had the map sensor do that to me on my dodge
    well actually we just got a map sensor for it lol gonna throw that in it and see what happens. fingers crossed!

  4. #4

    Default

    Ok so the map sensor made no difference. i guess ignition module is next What if that doesnt fix it? i have no idea what else it could be lol its weird it will drive along just fine then randomly the gas pedal will go dead then it comes back to life. then shortly after it usually the gas pedal will stay dead and stall when i come to a stop and it wont re-start till its cold again

  5. #5

    Default

    Have you hooked a timing light to it out of curiosity?

  6. #6

    Default

    I agree with the ignition mod. You could also try the throttle position sensor.
    You have enemies? Good. That means you've stood up for something, sometime in your life.
    Winston Churchill

  7. #7

    Default

    Are you getting fuel?! Change the fuel filter and see what happens. If it still dies, pop the air cleaner off and have someone turn the key while you look in the TBI. It should spray when they turn the key to the "on" position and when they crank it over after a second the fact that it starts after it's cooled off also makes me wonder if there's crap in the tank (maybe getting suck up to the strainer). After sitting for a while it's going back to the bottom of the tank resulting in the ability to start the truck. I would pull the tank regardless and clean it out if the truck has say for a long period of time before your purchase. This should give you a few avenues.

  8. #8

    Default

    maybe you have water in the fuel? My solution is to drain fuel and put new fuel in the truck. Then install a V8 and get on it!!! lol
    Buy Made in USA, The job you save just might be your own.

  9. #9

    Default

    x2 on the fuel filter. Also might want to check the egr valve.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  10. #10

    Default

    Any updates?

Page 1 of 3 123 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •