GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9

Hybrid View

  1. #1

    Default Need Assistance/Advice - Issue with Stereo in '03 Silverado

    Greetings,

    Just bought my son a 2003 Silverado Extended Cab LS in beautiful condition. The only issue with the truck was the front speakers, which were "crackling," so I assumed they were bad. I just got done replacing both woofers, and to my surprise, the "crackling" sound remained. Out of curiosity, I played a CD, which sounded perfect. For some odd reason, on AM/FM radio, there's a "crackling" sound coming from the speakers. It's not a lack of signal or static, as the radio will seek to the local stations just fine.

    Any idea why the radio would "crackle" like this, yet sound perfect using the CD player? I assume that means it can't be the amplifier, or it would sound the same on all sources.

    Thanks!

  2. #2

    Default

    Yeah. Maybe the antenna is shorting out somewhere?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  3. #3

    Default

    Is this like a faint crackle? Or is it even louder than the music?

  4. #4

    Default

    Thanks for everyone's help, but I was able to resolve the issue...I only had time to replace the driver side speaker the other day, and replaced the passenger side speaker this evening...After replacing both speakers, the system performance was completely restored, and I must say, it's not bad for a stock system, particularly when listening to CD's...

    I removed the fabric cover on the old woofers, and found the foam surround had completed disintegrated, leaving the cone floating with no support...What I believe happened was the voice coils on both speakers were grounded on the magnet, causing the entire system to "short out" in a sense...I now wonder what the condition of the rear door speakers is, even though they aren't exhibiting any issues at the moment...

  5. #5

    Default

    Photos. Photos. Photos.

  6. #6

    Default

    OK, for you inquisitive types , here's a picture of one of the woofers...Both were in the same condition...Notice that the foam surround deteriorated completely as is missing entirely...The foam surround is what stabilizes the drivers cone, and positions the voice coil in the magnet slot...Without the foam surround, the voice coils were grounded on the magnet, causing all sorts of havoc...

    For simplicity sake, I just bought the stock Delco speakers on eBay for $25 each, so it was just a matter of popping the old one out, and replacing it with the new one...If anyone has distortion, crackling, or other symptoms, I'll bet your woofers are shot like mine were...I was actually quite surprised at how good the system sounds on CD's, so I see no need to upgrade the speaker components...

    Click image for larger version. 

Name:	photo.jpg 
Views:	27 
Size:	66.8 KB 
ID:	55661

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •