GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Post 2001 1500HD Crew Front End Noise Experience

    Hello all, new member here looking for a solution. I've owned this baby from day one it has never wanted for anything long and with 210k its had all 40+ oil changes from none other than yours truly. I write because im spending hard earned $ on not fixing the problem I consider myself somewhat mechanically inclined and this is driving me nuts. Problem.... steady clicking noise forward or reverse at low speed (10+) mph im sure at higher just cant hear as well no turning of wheel required to make this happen either.. ive replaced the following with no reslove... hub/wheel bering assy ,half axle, inner tie rods, sway bar links, ldler arm but not the pitman yet, upper ball joints are about ready diff fluid level good, I'm at a loss any idea what im missing?

  2. #2

    Default

    ****Thread Moved****
    to the
    Chevy/GM General Tech Section


    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    Put all four corners in the air and drop it in drive, have someone give it enough gas until you hear the clicking.
    My suspicion is your gonna find the problem in the rotating part of the drivetrain, gears, axle shafts, wheels, etc.
    Since you already replaced some of these parts they will be easy to eliminate.
    Concentrate on parts that havent been changed, brake pads, rotors, clips behind the wheels, hopefully you get the idea.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •