GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default need climate control help

    I have an 04 silverado 1500 a few days ago i went to turn the a/c on and it works fine the problem is the vent position switch isn't working--all i have is the defrost position-any where else i set it it just keeps blowing the air on the windshield- what could the problem be?????
    --- the problem seems to have started when i unhooked the battery to put power to the foglights-could this have done something??
    Last edited by bart6180; 07-08-2008 at 01:06 PM.
    I didn't do it. nobody saw me do it, you can't prove anything

  2. #2

    Default

    There are a number of posts on problems with the climate control. Mostly that it blows hot on cold or cold on hot. Mine was blowing hot on one side and cold on the other. Any how the fix was to disconnect the positive terminal to let the computer reset as it seems some logic glitch was causing the problem. So I tried it which corrected my hot/cold issue but then stuck the vent position on defrost like you are talking about. After about hour of being stuck, the system finally starting working properly and has been working great every since. So you might give disconnecting the positive again (which seems to have caused it to start) for about 5 min a try.
    Last edited by curtisjon; 12-02-2008 at 11:07 AM.

  3. #3

    Default

    as weird as it may sound, curtisjon might be right. it's GM, one never knows. i'd leave it overnight with battery disconnected, there supposed to be some residual codes and "memories" that don't go away for long time in ECM.
    DON'T FIX IT IF IT AIN'T BROK. IF IT'S BROK - FIX RIGHT AWAY.
    WONNA THINGS DONE RIGHT, DO THEM YOURSELF

    2000 SILVERADO, CENTURION EDITION, 4WD, Z71, 5.3 VORTEC
    NO DUMM MODS

  4. #4

    Default

    thanx for the info-the blower started functioning good again about a month and a half ago, but am still having the problem you mentioned of blowing hot on cold and blowing cold on hot, i'll try unhooking the battery and see what happens
    I didn't do it. nobody saw me do it, you can't prove anything

Similar Threads

  1. Climate Control fan
    By metalchecker in forum General Chevy & GM Tech Questions
    Replies: 8
    Last Post: 05-05-2010, 12:19 PM
  2. 05' climate control
    By TroyT in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 04-20-2010, 10:56 AM
  3. Need new Climate control
    By twarner776 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 02-10-2009, 08:58 AM
  4. Climate Control
    By punkdu in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 2
    Last Post: 01-25-2009, 12:22 AM
  5. Auto Climate Control
    By 2500HD in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 01-05-2007, 09:15 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •