GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Jr. Apprentice
    Join Date
    Jan 2008
    Location
    Upstate South Carolina
    Posts
    19

    Default 2001 Suburban 2500 won't start after running out of gas.

    I have read the forums and I know it might be the fuel pump. Prior to this for 2weeks the gas gauge stopped working and the low fuel light stayed on. I don't know if this had anything to do with it. My son has been driving it as I have been down due to surgery. He parked it and it when he got back in it would run until you put it gear. He added gas about 4 gallons and tried and it just got worse until it wouldn't crank at all. Looking into the simple things first prior to towing it to my tech. Any advice would be appreciated !

  2. #2

    Default

    If you turn the key to "ON" (run) can you hear the pump? It is in the tank, someone should hear it if standing near the rear of the truck.

    If no sound, it still might not be the pump. There should be a pump relay in the underhood fuse panel. Try swapping it with an other relay that is the same.

    If still no luck, it could be a wiring problem at, or near, the tank. Perhaps a bad tank ground.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Jr. Apprentice
    Join Date
    Jan 2008
    Location
    Upstate South Carolina
    Posts
    19

    Default

    Thank u for the quick reply and the advice. I will try these out and post tomorrow.

    - - - Updated - - -

    I did the relay swap but it was a no go. I will get someone to help me listen for the pump. Also I discovered that the oil wasn't registering on the dip stick, I told my son to keep an eye on it as it takes a quart added between changes anyway, but you see how that went. I added oil and it still turns but will not take off. How about the fuel filter could it be completely clogged ? Thanks for the advice so far !

  4. #4

    Default

    Quote Originally Posted by buzzkutt View Post
    Thank u for the quick reply and the advice. I will try these out and post tomorrow.

    - - - Updated - - -

    I did the relay swap but it was a no go. I will get someone to help me listen for the pump. Also I discovered that the oil wasn't registering on the dip stick, I told my son to keep an eye on it as it takes a quart added between changes anyway, but you see how that went. I added oil and it still turns but will not take off. How about the fuel filter could it be completely clogged ? Thanks for the advice so far !
    You could always go "rent" at fuel pressure tester from an auto parts store. It would help indicate if it is even a fuel delivery issue or not.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  5. #5
    Jr. Apprentice
    Join Date
    Jan 2008
    Location
    Upstate South Carolina
    Posts
    19

    Default

    Well we had to push it to my driveway and my driveway is pretty steep so I let it sit on the hill. After sitting for awhile I tried it and it started and ran a little rough but it soon cleared up and ran. I am going to fill it up and see what happens. I am going to replace the filter and run some fuel cleaner in it tomorrow.
    L

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    Quote Originally Posted by buzzkutt View Post
    Well we had to push it to my driveway and my driveway is pretty steep so I let it sit on the hill. After sitting for awhile I tried it and it started and ran a little rough but it soon cleared up and ran. I am going to fill it up and see what happens. I am going to replace the filter and run some fuel cleaner in it tomorrow.
    L
    the fuel pressures need be checked. also if the vehicle has low fuel in it the pump gets hot//very hot..after 2 or 3 times with a no fuel condition the pump is all done ...

    many have these issues with operating with less than 1/4 tank.. quite common with the young drivers that do not have to pay for repairs//towing ..

  7. #7
    Jr. Apprentice
    Join Date
    Jan 2008
    Location
    Upstate South Carolina
    Posts
    19

    Default

    My Suburban is used primarily to move our camper and boat. Prior to my surgery I drove it to work occasionally. My son who is without a car has been using it since I couldn't for 2 months. I specifically told him keep it above 1/2 ! So yes, younger driver that doesn't think about what could happen if I don't keep gas and oil in a car. He is learning real quick ! He has bought all the parts and gas so far, that 30 gallon tank was expensive to fill up with non-e gas! And if the pump is bad he is buying it! Also he will have to help me change it and listen to me bit h the whole time. Thanks for the information !

  8. #8

    Default

    Considering that you have managed to get the truck to start, I suspect your pump is fine. You may have picked up some dirt, so replacing the filter (if it is outside the tank) is a good idea.

    Consider, that the bottom of our tanks is a very large flat surface, a gallon of fuel doesn't raise the level very far.

    I do not subscribe to the theory of the pump needing to be submerged in fuel to keep it cool. Even GM would not design a system where the tank must be kept 1/2 full to ensure the longevity of a mechanical pump.

    I do know that pumps, such as the design used by GM, do not like to be run dry. The fuel keeps the internal parts lubed, lack of internal lubrication is what kills the pump.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9
    Jr. Apprentice
    Join Date
    Jan 2008
    Location
    Upstate South Carolina
    Posts
    19

    Default

    The filter change improved it and it continues to run. I have driven to town and back with no problem. The gas gauge is still reading empty and the low fuel light is still on. I can live with that.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •