GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default turn signals/brake lights problem

    I am having a problem with the turn signals and brake lights on my 1998 extended cab chevy z-71 stepside truck. I noticed that when I used my turn signals, they appeared normal until I applied the brakes. One I pressed the brake pedal, the turn signal began to blink faster than normal as if they had a burned out bulb. The passenger side front bulb was burned out and changed, but the problem continued ! The turn signals although blinking fast were dimly lit. When I turn the head lights on I noticed that I didn't have any rear running lights at all. When I remove the rear tail light assembly to check the bulbs, the plastic around the metal tabs that hold the assembly to the truck were broken, preventing me from reassembling it. I just ordered a new set of rear tail light assemblies from E-bay with the new circuit boards included ! Im not sure where the problem lies ? I have a trailer light wiring harness kit with the "T" section that plugs into the rear tail light harness ! could that be a possibility ? What about a brake relay or flasher fuse?
    I am a fix it myself kind of guy and hate to pay a shop big bucks for a possible simple fix !!! Any help would be appreciated !!!! Thanks

  2. #2

    Default

    Without being there to help you test it, I can only offer an observation. Usually when turning on additional lights causes the first set of lights to go from full brightness to half brightness, there is a problem with a ground.

    I don't know if the rear lights have a ground wire that runs to the front (to the battery), or if they relay on a body ground. A check of all rear grounds might find the problem. You have already found one problem and the new set of circuit boards will solve that. The new boards may also fix the ground problem.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Thanks Ray for the prompt reply !!! Ill check the circuit boards when I recieve the new tail light assemblies ! Then I'll check the grounds and trailer wiring harness connection !!! Its a start !

    - - - Updated - - -

    Thanks again Ray, After checking the ground on the rear of the trucks tail light harness, I found it to be slightly loose ! after cleaning the connection a retightening the bolt, it worked like a charm !!!

  4. #4

    Default

    Glad it was an easy fix, thanks for reporting back, it may help someone else down the road.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #5

    Default

    Just curious....Would a ground issue cause brake lights to not work at all? I have all other light in the back working...just not brake lights.

    Quote Originally Posted by RayVoy View Post
    Glad it was an easy fix, thanks for reporting back, it may help someone else down the road.

  6. #6

    Default

    Quote Originally Posted by GMANs95 View Post
    Just curious....Would a ground issue cause brake lights to not work at all? I have all other light in the back working...just not brake lights.
    Probably not, I would suspect bulbs, fuses, switch, circuit boards or wiring (in that order).

    A common GM brake circuit would see power from a fuse, going to the brake light switch (on, or under the pedal), to a 2nd and 3rd fuse. These two fuses split the brake light wiring, one fuse passes power to the center brake light, the other fuse passes power to the side brake lights.

    So, if no rear brake lights, suspect the brake light switch, it is either bad, or out of adjustment.

    If no side lights, but you have the high center, suspect the side bulbs are burnt out, or the fuse for these two lamps.

    If you are sure the two bulbs are good and the fuse is good, you need to check the circuit board for 12v, and/or ground. If you have both 12v (when brake is applied) and ground, it could be the circuit board.

    However, the most common problem is 2 burnt out lamps. Check them very carefully.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •