GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default '99 Silverado: Sending Unit? Fuel Pump?

    Hi all,

    I have a '99 Silverado Extended Cab 5.3L 4x4. Every time I start it up and get underway, the truck hesitates - doesn't seem like it's getting enough fuel. This lasts for, oh, 15 seconds or so. After that, it runs fine, with plenty of power. No matter how long I drive, once I shut her down and start her up, I experience the same problem again, but still only for about 15 seconds.

    Another thing is that 90% of the time, my fuel gauge reads 'E' (but I know it's full). Oh, and it doesn't seem to matter how long I idle at startup - the problem still crops up when I get underway.

    I'm figuring, with my vast knowledge (not!) that the "E" fuel gauge indicates a bad fuel sending unit, no? I don't know if the fuel pump is suspect also or not.

    I'm wondering - if I replace, or have replaced, the sending unit, is that much less of a hassle (in terms of time and effort, a.k.a., MONEY) than replacing the fuel pump? If it's about the same amount of hassle I will probably just get the fuel pump switched out - which I know can be a pain (don't fuel pumps come equipped with sending units?). I be inclined to throw some F.I. cleaner at it and see, but the "E" fuel gauge makes me think it's not just cruddy fuel injectors.

    Thanks

    Jed

  2. #2
    Jr. Engineer Rumpamuro's Avatar
    Join Date
    Apr 2007
    Location
    Mississauga, Ontario (Canada)
    Posts
    233

    Default

    Try changing your fuel filter first, but most likely if you havent changed the filter in a while, a) youve probably damaged your pump in the means of over worked it cus the pump can be sending out ex. 100psi but the pressure after the filter may only be like 35psi, and b) if you havent changed the filter in a long time good luck not breaking any lines.

    Another thing are you saying you can shut her off and imediately start her back up again and it does it once again? or you mean wait a while and then start her up? could also be a bad check valve.


    EDIT: Another thing about the time and hassle, replacing your fuel pump can be easy if you dont mind cutting the sheet metal of the bed, or else, drop the tank a bit undo all harnesses, lines, vents etc, and then fully drop the tank, and swap the pumps with sending unit usually and reverse. alot of customers ie. contracts, rather pay only half the labour and let us cut the bed on there older trucks.
    Last edited by Rumpamuro; 07-16-2008 at 02:25 PM.
    --> Rocco "Rumpamuro"

    --> Apprentice Mechanic (Cars and Trucks)

    --> Mississauga, Ontario (Canada) eh!

    --> Vehicles on the driveway:

    -2008 GMC Acadia SLE AWD

    -2007 Silverado Classic Reg cab, long box.

    -2008 Pontiac Vibe (my dads fuel efficient way to go to work)

    -1996 Pontiac Sunfire GT

  3. #3

    Default

    No way of knowing on the fuel filter - I have only owned the truck for a couple weeks, and the used car dealership doesn't seem to know anything about it.

    I haven't tried starting it RIGHT up after shutting it off, but I've had it shut off for 60 seconds and it still does it. So I don't know if that answers the question or not.

    As for cutting the bed, I'd rather drop the tank. Other than this issue, the truck is cherry and I couldn't bear to cut the bed, even to save some dough.

    Thanks for the input!

    Jed

  4. #4

    Default

    and the thing with your fuel gauge is a common chevy problem, for some reason my truck doesnt do it but all 3 guys i work with that drive chevy's range from 97 - 2007 have this problem

  5. #5

    Default

    I replaced the fuel filter, and the hesitation remains. I did come to realize that the truck can sit for a few minutes (turned off) and when I start up again, there is no hesitation. It's only after it's been sitting for more than 5 or 6 minutes (more or less) that it happens. But at least I got a new fuel filter out of it!

    I had a '97 GMC Suburban, and I didn't ever see this problem - although the fuel pump died a slow and painful death just before I traded it in...

  6. #6
    Jr. Engineer Rumpamuro's Avatar
    Join Date
    Apr 2007
    Location
    Mississauga, Ontario (Canada)
    Posts
    233

    Default

    Was the filter clogged at all ??
    --> Rocco "Rumpamuro"

    --> Apprentice Mechanic (Cars and Trucks)

    --> Mississauga, Ontario (Canada) eh!

    --> Vehicles on the driveway:

    -2008 GMC Acadia SLE AWD

    -2007 Silverado Classic Reg cab, long box.

    -2008 Pontiac Vibe (my dads fuel efficient way to go to work)

    -1996 Pontiac Sunfire GT

Similar Threads

  1. Fuel sending unit
    By jayfire in forum General Chevy & GM Tech Questions
    Replies: 15
    Last Post: 09-22-2009, 09:27 AM
  2. fuel sending unit help-81 K20
    By bart6180 in forum Chevy C/K Truck Forum
    Replies: 7
    Last Post: 05-17-2009, 10:54 AM
  3. Replies: 3
    Last Post: 02-27-2008, 04:19 PM
  4. Fuel Pump test wire/oil sending unit/ignition mod
    By odb138 in forum Performance & Fuel
    Replies: 3
    Last Post: 01-29-2008, 12:16 PM
  5. Fuel Pump Test Wire / Oil Sending Unit/ Ignition Module
    By odb138 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 01-28-2008, 03:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •