GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1
    Jr. Apprentice
    Join Date
    Nov 2013
    Location
    Gardner, Colorado
    Posts
    11

    Default problem with DIC check reset and customization buttons

    I'm trying to reset my average economy readout and holding the check/reset button does not do it. Additionally I'm not able to use the customization button to reset the system default or customize the feature settings. Any input would be greatly appreciated. I have read the book and I think I'm following the direction correctly.
    thanks
    DB
    08 Silverado LTZ 2500HD CCLB 4x4 Duramax LMM Allison

  2. #2

    Default

    Hello bdflyrod,

    I am sorry to hear that you are experiencing an issue where you cannot reset the average economy readout. I would like to look into this concern for you. Please private message if I can be of any assistance.

    Jennifer T.
    GM Customer Care

  3. Thanks dbflyrod thanked for this post
  4. #3

    Default

    I'm not a big fan of doing battery disconnects, but sometimes it is the solution.

    Maybe you DIC needs a re-boot/reset, try a battery pull.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #4
    Jr. Apprentice
    Join Date
    Nov 2013
    Location
    Gardner, Colorado
    Posts
    11

    Default

    Quote Originally Posted by RayVoy View Post
    I'm not a big fan of doing battery disconnects, but sometimes it is the solution.

    Maybe you DIC needs a re-boot/reset, try a battery pull.

    Thanks RayVoy I did try that to no avale. I actually had a half hour finding out about the Pass key 3 + thing and did the battery deisconnect to see if I could fix that. Ended up doing the key on for 10 minutes thing to get through it. I think I either have a didconnect on the button cluster or bad buttons. I'm curiouse though as to why 2 buttons would be inop thus leading me to think more along the lines of wireing disconnect.
    DB
    08 Silverado LTZ 2500HD CCLB 4x4 Duramax LMM Allison

  6. #5
    Jr. Apprentice
    Join Date
    Nov 2013
    Location
    Gardner, Colorado
    Posts
    11

    Default

    DIC is now working, thanks to all. I ordered a new switch from GM parts club, received it today and plugged it in, yeah!! it worked. After braking down the old switch to the circuit board I found some whitish like corrosion around the check/reset button area.
    08 Silverado LTZ 2500HD CCLB 4x4 Duramax LMM Allison

  7. #6

    Default

    Sounds like water damage, clean it and it may be a good spare.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •