GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Lots of questions!!! Need help ASAP!!!!!

    Alright, I've got a 2004 z71 with a 6 inch suspension lift and a 3 inch body. It has 108,000 miles on it and I'm having some problems. The first problem was a knock sensor. What I want to know is with these not being replace dose it hurt the truck performance wise at all or the mpg? Then I had an over heating issue. When I turn my a/c on and I'm driving in the summer time it will over heat and blow hot air every time. What could cause this? Then my service 4wd light came on. It would stay in 2wd and when I shift out of or back into it the light would blink saying it was an incomplete shift. I replaced the actuator and still had this problem. Then replaced a fuse under the dash and the light went away...... For a day or two. I think it's the motor but I want to make sure before I put the money into it. Now I have this noise while I'm driving. When I turn the wheel to the right I get a squeak but when I hit my breaks it goes away. And when I am driving straight I hit my brakes it makes a shuffling noise but I don't feel a shuffle in the peddle. I replace the front brakes and checked the hubs and they are fine. Any ideas? Now that it's getting cold I have this studded sound in the dash but it only makes it every now and then and when I turn my a/c direction knob the defrost the noise slows down but it's still there. And just yesterday I replace the inner tie rods, the pitman arm, idler arm, and the driver side upper control arm and went to get and alignment and the guy at the shop told me that I needed new "alignment locking plates and was going to change me $200 to put them in. "Seriously, it takes 30 minutes to do that job"! He told me that he can only do it because if I did it he would have to take them back off in order to do the alignment. Has anyone heard of this? And when I was leaving the shop I turned my wheel to the right and had a huge popping noise right under the driver side floor board? I need help guys. I am trying to sell this truck soon so I need help ASAP! Thanks

  2. #2
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,468

    Default

    when you or the previous owner does a lift as you have these costs and component breakdown will occur.

    alignment is a big job with your current height. the parts you replaced will effect the toe . the control arm will effect the camber possibly.

    the KS is 2 sensors mounted on the intake manifold under the upper intake manifold. these require replacing as they do effect timing . washing the engine is what causes this. no washing or this happens.yes MPG will be effected and possibly engine running hot/pinging pre-ignition.

    with the ac on and the engine temp rises this is usually the fan clutch. when the ac is on more heat causes the clutch to drive the fan more.

    air temp not cool check ac pressures hi and lo side and use the outside air temp to determine the status of the ac compressor/system operation.

    sounds when turning with a lift can be component rubbing issues.. I would look at the CV joints for wear.

    4wd the actuator is the front diff controller. the encoder is the transfercase controller. the encoder may be binding. check the transfercase fluid it should be blue.. if not blue replace. if after operating a few hundred miles the 4wd still is acting up you most likely will need a new motor.

    for 108,000 miles this truck is with more problems than most. how about 200,000miles on it.

  3. Likes GetOnMyLevelBlackZ liked this post
  4. #3

    Default Appreciate it!

    The odometer reads 108,000. All of these problems started around 100,000 miles. This truck isn't my toy either. It's my daily driver and the hardest thing I did in it was pull a ranger out of some mud even then I was in 2wd an wasn't getting on it. So, that cv joint would make that noise? I figured the camber being out would cause the truck the ride and turn rough but the pop was what I was worried about. Thanks for the help!

  5. #4
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,468

    Default

    well the raised trucks have wear issues ..now on the pop sounds this Is with my experience the ball joints. these do make the pop sound and depending on the tires etc you may not feel it in the steering wheel.. I would recheck them..

    with this lift setup it is best if done so that the cv/u joints are properly operating straight. any angling of these joints they wear at a faster rate.. the greater the angle the more they work.

    then the greasing of these front end components is needed and monitored so that they are always with grease. I use a lithium based grease ..I have only had to replace a very few tie rods and no ball joints over my too many years doing this work..

    when turning a bad cv will make noises ..easy to check ..I would also check all the U joints ..take out of gear and rotate shafts... see if they are worn ..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •