GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Oil Comsumption for 5.3L AFM Engines No Longer an Issue for 2012-2013?

    According to a TSB I read, has the oil consumption problem for 2012-2013 AFM engines no longer an issue?

    Does anyone on the forum have a 2012 or 2013 AFM engine that consumes oil?

    I disabled AFM on my 2013 and when I changed the oil after over 5000 miles, I was maybe 0.25-0.5 quart low. I think less than a quart after 5K miles is acceptable oil consumption for any engine.

    Thanks.

    https://www.google.com/url?sa=t&rct=...57155469,d.cWc

    2013 Silverado LTZ White Diamond Crew Cab


    Mods:
    Advent OGM1 Navigation
    Husky Liners GearBox Underseat Storage
    Airaid MIT
    EGR Rail Caps
    K&N Air Filter
    Flowsound 40 Muffler
    Hypertech Max Energy Tune (only top end limiter removed and AFM disabled)
    Chrome Tailgate Handle Cover
    TonnoPro HF-155 Tonneau Cover
    WeatherTech Front and Rear Splash Guards
    Husky Liners X-Act Contour Floor Liners
    WeatherTech Side Window Deflectors

  2. #2

    Default

    My 5.3 is a 2011 and I dont have an oil consumption issue, but I only have 10 k miles on her, and to be on the safe side, I am adding the AFM range technology device next month, just in case. I have put about 3500 miles on it since the last oil change, and its still running on a full belly, no loss of oil so far. I will assume that I will have issues given the scope of this problem.I often wonder why some shade tree greedy lawyer has not jumped all over this with a class action, they normally get wood over stuff like this, lol
    Life is short compared to history

    Rick (summitwhite11)

  3. #3

    Default

    Quote Originally Posted by summitwhite11 View Post
    My 5.3 is a 2011 and I dont have an oil consumption issue, but I only have 10 k miles on her, and to be on the safe side, I am adding the AFM range technology device next month, just in case. I have put about 3500 miles on it since the last oil change, and its still running on a full belly, no loss of oil so far. I will assume that I will have issues given the scope of this problem.I often wonder why some shade tree greedy lawyer has not jumped all over this with a class action, they normally get wood over stuff like this, lol
    My guess is it is happening to ~1% of the AFM engines out there.

  4. #4

    Default

    Quote Originally Posted by stchman View Post
    My guess is it is happening to ~1% of the AFM engines out there.
    its good that it may not be wide spread, I would hate knowing my well loved truck was doing that,

  5. #5

    Default

    I think the issue was solved by time the 2011 trucks were brought to market.
    It normally shows up on trucks from 2007 to 2010.

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,353

    Default

    Should not be a problem anymore I think GM took care of THERE problem..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  7. #7
    Jr. Engineer Cowpie's Avatar
    Join Date
    Jun 2013
    Location
    Central Iowa
    Posts
    216

    Default

    I had been away from gasser for a decade, and while waiting for the dealer to get my 2013 Silverado with 5.3L ready for me, I started checking out things about it and ran across this AFM oil burning issue. I was not going to play a wait and see game to see "if" GM had gotten their act together on these AFM engines. I put on the Range AFM delete module at 240 miles on the odometer. At 1200 miles, it got the first oil change and filled with synthetic. At the same time, I put on a PCV oil catch can to keep oil out of the intake and creating deposits on valves. Hoping that, if there is still some issue with oil consumption, that these preemptive strikes will prevent bad things. Will probably get around to just doing an ECM tune in the near future. More than likely, the Diablo tune with Lew's enhancements.
    Hey there, VA, what do ya' say? How many vets did you kill today?

  8. #8

    Default

    Wow the stuff I find out here is amazing, I have a 2008 with AFM. It was my dads truck, when he had it something broke or bent (I think a lifter or a pushrod, may have even been a rocker) due to the AFM. needless to say everything has been replaced in the top of the engine and she runs great now. But........now Ive had the truck about 2 months now and I noticed when I check the oil it is usually low. It has 153,000 miles on it now could this be due to the AFM????

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •