GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default shifting problems - maybe the first sign of a necessary rebuild?

    On a long road trip today, the Burb seemed to be hard shifting at low speed. Kind of a clunk sudden jerk feeling versus a smooth shift. At higher speeds I didn't notice it.

    I noticed this behaviour once before. The problem seems to come after driving a bit. Slow acceleration seems to be fine, it's the middle acceleration speed that seems to trip it up, and only occasionally.

    I'm thinking of having the transmission fluid flushed. Any insight would be appreciated.

  2. #2

    Default

    YEah, I would start with the filter and fluid, if you havent done them in a while...

    2007 Silverado LT Z71 4x4 Crew Cab
    Dark Metallic Blue

    Mods to come, just purchased on 10/31/09

    Go Pack Go!

  3. #3

    Default

    low transmission fluid would possibly cause this issue. The second thing I would think that could do this is low pressures as a result of either the valve body or the front pump. No matter what, it doesn't bode well, although the valve body is theoretically easier to do since you can get to it without removing the whole transmission.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 277K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

  4. #4

    Default

    The problem doesn't occur very often. Drove the burb today and didn't have a hiccup.

    I'll run the truck thru a transmission flush and keep my fingers crossed.

  5. #5

    Default

    Quote Originally Posted by Crawdaddy View Post
    low transmission fluid would possibly cause this issue. The second thing I would think that could do this is low pressures as a result of either the valve body or the front pump. No matter what, it doesn't bode well, although the valve body is theoretically easier to do since you can get to it without removing the whole transmission.
    Looks like you were right. I had the valve body replaced, fluid flushed and new filter. The repair wasn't too bad in cost in my opinion. I'm just glad it didn't need a complete rebuild.

  6. #6

    Default

    Did you do the valve body replacement yourself? How was it determined that the valve body was bad? For me, it wasn't too bad, and I just used a shift-kit to do the rebuild on the valve body. Pretty much the only things that can really go wrong is the springs weaken or break, and a good shift kit replaces all the springs anyways... Glad you figured out the issue.

  7. #7

    Default

    Quote Originally Posted by Crawdaddy View Post
    Did you do the valve body replacement yourself? How was it determined that the valve body was bad? For me, it wasn't too bad, and I just used a shift-kit to do the rebuild on the valve body. Pretty much the only things that can really go wrong is the springs weaken or break, and a good shift kit replaces all the springs anyways... Glad you figured out the issue.
    I took it to a transmission shop. Based on the mileage on my burb, only 90k, the guy at the shop felt that was probably the issue. He inspected it and told me that was the case. The hard shifting problem is gone.

Similar Threads

  1. Transmission shifting problems..
    By JRD761 in forum GM Powertrain
    Replies: 5
    Last: 07-12-2010, 08:32 PM
  2. Down shifting problems
    By tate96 in forum Member Introductions
    Replies: 7
    Last: 02-24-2010, 06:46 PM
  3. 1st gear shifting problems.
    By Stellarex in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 10-01-2009, 08:32 AM
  4. hard starting/engine lagging/shifting problems
    By 99sliverado in forum GM Powertrain
    Replies: 24
    Last: 05-04-2009, 03:23 PM
  5. 93' 1500 shifting problems
    By ftball2307 in forum GM Powertrain
    Replies: 0
    Last: 08-29-2008, 05:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •