GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 88 C3500 Radio/headlamps/dash lights/ running and clearance lights inop

    My one ton was running great. I was driving down the highway when the radio quit working. Didn't like the song, so did not think a lot about it. The issue I am having is that all of the lights except brake and turn also stopped working. I replaced the headlight switch, pigtail to switch. No luck. All fuses are good. Since my Durango gave up the ghost last night, I am down to the one ton to drive. Any thoughts??

  2. #2

    Default

    Did you check the relays?
    I like all dogs I meet, and some people too.

  3. #3

    Default

    I don't have a copy of your wiring diagrams, but I have a suggestion. Start with one problem, I would use the running lights, and track the voltage. Needless to say, you will need a volt meter (just buy a cheap one), start at one light and move back to the battery, checking all switches and fuses in the circuit for 12 volts.

    You'll find it is something common to all things not working, probable a main wiring connection, or a megi-fuse.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •