GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Tail lights not working

    I just noticed this "warning ticket" on my desk. I have three days left to find out why the tail lights are not working on my '98 suburban. reverse and brake lights are OK.

    Did some checking the other night. I took out the trailer connector (one of those "T" plug-ins). There was no power at the connector where this "T" was installed. The wires to the trailer connector were a mess, lots of bare spots, so I took it out for now.

    Is there a mystery tail light specific fuse. I checked all the fuses I could find and they are good.

    Where is the next connection to check. Bulbs are good, and no power to the tail light assy.

    Is there an accessible place in the front to start from?

    Doesn't matter which end I start from.

    Thanks for any input.

    Carl

  2. #2

    Default

    Bad ground is a possibility. Re ground one of the wires that are supposed to be on, with a multimeter or light tester and see which direction you need to start looking in.

    Do the license plate lights work with the lights on? Those should be the same circuit.

    '93 Pontiac Bonneville SE | Series I Buick 3800 L27 | Dark Yellow Green | 3.06:1 | | 225/60 TripleTreds 2/9/08 | 106k | The Mean Green Machine
    '04 Chevrolet Avalanche 1500 Z71 4x4 | Gen III Vortec 5300 LM7 | Summit White | 3.73:1 | XM, Bose 6 Disc Changer | 12-way Heated Leather | 58k


  3. #3

    Default

    Thanks for the reply. I used a test light at the connector by the hitch, where the trailer light adapter was plugged in and got nothing. license lights were also dark, so it seems the whole circuit is dead. the reverse and brake lights work OK so the ground must be good to the tail light assemblies.

    Is my troubleshooting brain headed the right direction?

    I probably need to get my hands on a wiring diagram with connector locations and start tracing. I was hoping someone could lead me to a couple of connectors so I could narrow it down

    thanks again!!

    Carl
    Last edited by carlsauction; 08-05-2008 at 08:41 PM. Reason: typo

  4. #4

    Default

    I HATE when I overthink things.

    As I took another look under the back of my sub this morning, I noticed a spot in the harness with black tape on it. As I checked it out, it was obvious that a previous owner had spliced in a trailer connector at some point. Seems like the combination of time, miles, moisture, gravel roads, those damn crimp-on connectors and cheap electrical tape, caused the tail light wire to corrode through.

    Like most wiring issues.....long hunt, short fix.

    Carl

  5. #5

    Default

    make sure you coat all exposed connections, such as that, with dielectric grease to prevent that from happening again. In the past, when I've gotten a car, or had a friend get a car, I usually take a few hours, and clean and apply it to the grounds and important charging system components. No corrosion on it always makes it easier to deal with battery connections and such later as well.

    glad to hear you found it.

  6. #6
    Newbie RichStom's Avatar
    Join Date
    Feb 2009
    Location
    Lake Charles, Louisiana
    Posts
    8

    Default

    I know this is an old topic but I have an 06 silverado with the same problem but I'm
    curious to actually know what you did to fix this problem? Did you just cut
    back a fresh part of the wire? My blinkers and break lights work but no license plate lights or standard running light.

  7. #7
    Newbie RichStom's Avatar
    Join Date
    Feb 2009
    Location
    Lake Charles, Louisiana
    Posts
    8

    Default

    Bump•. Please any help is appreciated.

  8. #8

    Default

    I cut out the section of wire with the old splice and put in a crimp connector and wrapped it with black tape. I looked under there a few days ago and the tape is all dried up and starting to come off. I need to hook up a trailer connector again and my plan is to cut out the crimp connector and use a 3-wire crimp connector (one that you insert the two original wires and the one for the trailer plug) I will put the dielectric grease on the wires then coat any openings in the connectors with liquid electric tape.

    The best way would probably be to solder the wires together then coat with the liquid electric tape. But my Suburban has 225,000 miles so I'm not going to spend too much time and effort on it.


    hope this helps

    Carl

Similar Threads

  1. 04 Tahoe Rear tail lights not working
    By bulldawg06 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 11-25-2012, 02:03 AM
  2. 82 K10 Tail and Reverse Lights Not Working!
    By ahobson1 in forum Chevy C/K Truck Forum
    Replies: 7
    Last: 06-20-2010, 08:08 PM
  3. Rear tail lights not working
    By floutlaws in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 08-22-2009, 10:21 AM
  4. Trading My Stock Tail Lights for Euro Tail Lights
    By ippielb in forum Chevy Truck Accessories
    Replies: 5
    Last: 07-10-2009, 11:50 AM
  5. Lost dash lights and tail lights???? [Expired Topic]
    By martone68 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 03-12-2006, 07:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •