GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 2008 Z71 Silverado "service 4 wheel drive" after dead battery

    The other day I had a dead battery. As soon as I put the key in the ignition it said I needed to service the 4 wheel drive. It didn't have enough juice to start the truck so I had jump it. It's throwing the code U0102 (lost com with transfer case control module) the remote start won't work now and the trans doesn't want to drop into passing gear when I gun it. I've alread tried pulling the fuse on it and I have left the battery on a charger for the last two days. Its nice and charged now, but I'm still getting the message. The truck also has 189K miles. Ideas?

    Thanks for the help

  2. #2

    Default

    Same exact thing happened to me two days ago, have you had any luck figuring this out?

  3. #3

    Default

    Nothing. Ive been away from the truck for 4 days and haven't been able to try anything else. I suspect the switch fried and thats what drained the battery. The daily highs were in the minus teens every day. For a week. It sat for four days without running. Its started up and I drove it home. (20 min drive) then I tried to start it the next morning and it was dead.

  4. Thanks Colby4x4 thanked for this post
  5. #4

    Default

    Mine keeps draining as we'll, took an hour trip yesterday, and noticed the switch was really hot, I suspect it to be the culprit too. I have a switch on order to see if it fixes the problem, I will keep you updated.

  6. Thanks XJEric thanked for this post
    Likes XJEric liked this post
  7. #5

    Default

    Thanks man. I'd like to know!

    - - - Updated - - -

    I've heard there is a way to pull the switch apart and that the soldering can be fixed. I'm trying to figure out how to pull the thing apart. I tried and couldn't figure out how to do it. I'm tempted to try and switch it from the one in my suburban but it's only got 4hi and auto. The Z71 has 4 low too.

  8. #6

    Default

    I tried pulling mine apart as well, cant figure it out either

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •