GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 10 of 10 FirstFirst ... 8910
Results 91 to 94 of 94

Thread: 1999 S10 Xtreme

  1. #91

    Default

    Got the system out in and the throttle plate mod done this weekend. Also gave the truck a good washing.

    I ran the system wiring different than last time. I have the ground behind the flip down seat on one of the mounting nuts. Power wire ran through the antenna grommet under the passenger side carpet. The wires to the stereo are ran down the drivers side and under the dash. To the amp i have all the wiring under the carpeting along the back wall then poked it out right to the amp. The wiring to the sub i ran out from under the jack cover. I didn't put the under the carpeting just in case i need to move it around i can without have to pull the carpet up to get the wiring out.

    Some pictures have a lot of glare because of the sun but not horrible. Plus my lens being scratched does not help. But anyway here they are.

    Setup:



    Sub wiring. I may put a small section of loom on it. I have some left over:



    Amp:



    Ground:




    Now on to the throttle plate mod.

    Here it is taken out:



    I made myself a mark so i didn't cut in the plate itself. Just to be safe:



    Got it cut off. Just used my dremel and a small cut off disk. The a sanding wheel to clean up the rough edges:



    Then i just ended up taking the whole throttle body off to clean it:



    All cleaned up and put back in:





    Overall i gotta say it helped a whole lot on the response. I don't gotta step on it as much to get going and it's much more enjoyable to drive with the good response.

    Had to take a pic of it cleaned up. I was gonna polish it too but the paint was way too hot from the sun so i'll wait until another day:



    Then i saw this...A piece of plexi glass put in place of a window on this destroyed door.. well car i should say, using expandable foam from the can..... come on now.

    Last edited by 95_5spd; 04-13-2014 at 10:36 PM.
    95 S10 LS 5 speed ext cab 2wd "work truck"
    3/3 static _ Spectre Air Filter _ Punched out cat _ Glasspack>

    99 S10 Xtreme 3rd door, 5 speed 4.3 VIN W
    Hurst Short Throw Shifter _
    American Racing wheels (275/60/15; 215/70/15) _ Sub/Amp/Stereo _ TB Mod>

  2. #92

    Default

    Ordered my muffler and cat today. I got the Pypes Street Pro Muffler 2.5" instead of the race pro because i have been reading it's not as mellow and quiet as the race pro. Then i got the 2.5" Thunderbolt Spun Cat. The should be here by next Thursday and the muffler within the next few days.

    I have been working on detailing the truck as well. I'm doing it by hand so I do a little each day after work. Rubbing compound followed by Nu-Finish polish. I've gotten a good amount of swirl marks and light scratches out so far. It's like a mirror now. I'll end up doing a clay on it at some point but right now i wanna get the rubbing compound done and some polish to protect it. I have everything done besides the bed which i'll finish tomorrow. Looks real good. I've always loved how red cars looked real clean. I'll put pictures up tomorrow when it's done.
    95 S10 LS 5 speed ext cab 2wd "work truck"
    3/3 static _ Spectre Air Filter _ Punched out cat _ Glasspack>

    99 S10 Xtreme 3rd door, 5 speed 4.3 VIN W
    Hurst Short Throw Shifter _
    American Racing wheels (275/60/15; 215/70/15) _ Sub/Amp/Stereo _ TB Mod>

  3. #93

    Default

    Pictures are up now. Got some good ones once the sun went down













    (I still haven't gotten to brighten that fender up. Kind of annoying me now)




    I also fixed my rattling tail gate. The rubber that comes on the latch on these trucks are so soft it doesn't do anything once it get used enough and worn down. So i found on another forum someone used vac hose to make a new stop to eliminate the rattle. Mine was bad enough i could hear it with my back window open so i had to fix it. I didn't have vac hose but i found these little rubber pieces. So i cut them down to size and stuck them on there. Works perfect. Shut real tight and doesn't move at all.




    I'll have pics of when i put my exhaust in. Can't wait to hear it.

    Have a good Easter everyone!
    95 S10 LS 5 speed ext cab 2wd "work truck"
    3/3 static _ Spectre Air Filter _ Punched out cat _ Glasspack>

    99 S10 Xtreme 3rd door, 5 speed 4.3 VIN W
    Hurst Short Throw Shifter _
    American Racing wheels (275/60/15; 215/70/15) _ Sub/Amp/Stereo _ TB Mod>

  4. #94
    Master Mechanic BurbanMan's Avatar
    Join Date
    Jul 2013
    Location
    Dolores, CO
    Posts
    806

    Default

    Looking good!
    Chuckie!!!


Page 10 of 10 FirstFirst ... 8910

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •