GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10

Thread: no low beams

  1. #1

    Default no low beams

    mornin all....

    I have a 96 suburban, and have no low beams. Highs are ok, but pissing off other drivers. Possibly a ground issue? Also my lr turn signal is out, swapped bulbs and still not working....both issues related?

    Thanks!

  2. #2

    Default

    Quote Originally Posted by bessyblue View Post
    mornin all....

    I have a 96 suburban, and have no low beams. Highs are ok, but pissing off other drivers. Possibly a ground issue? Also my lr turn signal is out, swapped bulbs and still not working....both issues related?

    Thanks!
    Didyou check your fuses??? If thats not it check the wires goiung to your light sockets and make sure the sockets are clean and free of corrsion. One of those should do it. sounds like you blew a fuse or 2

  3. #3

    Default

    sounds like the head light switch is bad. $15 at napa and 10-20 min swap......mike
    Michael Collins
    1993 4X4 Suburban
    many other toys as well

  4. #4

    Default

    you might try the low beam relay as well as the switch check for voltage at both locations. As far as grounding issues go, its worth a look to check them out. The headlights are individually grounded just for the fact that if one goes out, you still have one for safety issues (like seeing a car at night with one headlight brighter than the other)Or you could try switchig the relays out to see if the problem follows to your high beams.

  5. #5

    Default

    I've got the exact same issue with my 96 silverado. I changed the bulbs, still nothing, I pulled the switch from another truck, didn't solve it. Where's the low beam relay?

  6. #6
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Bessyblue-

    As mentioned, the first check to always do is checking fuses. Have a quick look at the appropriate fuse (or take the time to check them all while you are there). Make sure to check both the cluster in the cab and under the hood.

    Next, start to troubleshoot from the front and work your way back...

    Grab your handy-dandy multi-meter and pull the headlight out. Test the socket (take out the bulbs and test the tabs inside). From there work your way out...test the interior tab and ground the (-) probe on a clean metal part of the truck, then do the same tests but by using the wires in back of the back of the plugs, etc etc.

    Hope this helps a little!
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  7. #7

    Default

    it is down towards the bottom of the steering column. it is $15 at most auto parts. it connects to the head light beam selection by a long steel rod....mike

  8. #8
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    I would as was said here in the other replies check the fuses first because that's the simpler way to go with it but if that's not it check to make sure your tail lights or brake lights aren't affected by it also if they are, it could be any one of the relays but if not I would still look at the beam selector relay like one of the others mentioned. MY wife has a 98 suburban which is pretty much set up the same as the older ones so if we ever have that issue we'll be going through the same thing. posts like this are helpful for everyone but I still go by what I have learned with all the other GM products I have had in the past with this same or similar type of issue and usually fuses and or relays are the source of the issue.

  9. #9

    Default

    Well, I asked a couple parts places about a low beam relay, and they looked at me like I had 2 heads. They said there's a relay for the headlight system as a whole, but nothing specific to low beams. I've been driving around with my hi beams on for months now, and just for fun the other night, I switched them off, and I had low beams! So when I got home, I tilted the column up like I usually do and they came off and wouldn't come back on again. I have reason to believe it's the multifunction switch on the side of the column, which is ridiculously expensive, and only available at the dealer.

  10. #10
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    actually the part it's self may be the most expensive part of the whole deal. Did you find out how much it would cost to do the actual switch replacement at the dealers yet???

    I do believe something like that may be a dealer only part. You might want to before you go the expensive route check the plug at the end of the column to make sure it's not just partially unplugged you can find it by fllowing the column down from the top there should be two metal rods and two long white skinny plugs at the bottom (don't mess with the rods those work your ignition) the long white square plug however if it isn't locked in properly could be part of your problem too. that could explain why the wheel being tilted is causing the low beams not to work. Or worse case scenario it could be the switch still too. That might be something else to check though before you go to the expense of replacing the switch.

Similar Threads

  1. I'm looking for a cheap way to engauge hi/low beams
    By stanstrif in forum GM Electrical Tech
    Replies: 4
    Last: 01-06-2010, 11:45 PM
  2. Limp mode activated with low beams
    By GlitchMobile in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-12-2008, 08:23 PM
  3. HID don't work-1998 Suburban-low beams-DRL disabled
    By phoebeisis in forum Chevy Truck Accessories
    Replies: 2
    Last: 05-06-2008, 01:41 PM
  4. 2001 No Low Beams
    By jhaney68 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 01-11-2008, 05:24 PM
  5. How to keep fog light on with high beams
    By ejamin73 in forum GM Electrical Tech
    Replies: 3
    Last: 11-26-2007, 12:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •