GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10

Hybrid View

  1. #1

    Default Check engine light is on

    Hi new to this but my buddy check the code on my 06 avalanche 5.3l and the code stated that my purge valve was either shorted or bad.so I replaced it still on any ideas please help and I was told to put a bulb In the connector and turn on the engine and should light up but it did not

  2. #2

  3. #3

    Default

    I will have to find out sry

    - - - Updated - - -

    Quote Originally Posted by Jeremx View Post
    I will have to find out sry
    Code is po446

  4. #4

    Default

    I went got a scan tool command the vent valve to open and close did I have voltage I preformed a test found not holding pressure meaning I have a crack in a line I'm told and need a smoke test done now hate trucks and cars at times lol thanks for the help and hope I can get someone to find the leak I guess dealers

  5. #5

    Default

    Welcome to the club!!! Yeah thats the pain with emissions testing. It basically keeps the fumes from escaping into the atmosphere and gets filtered through a carbon filter. If pressure is not building it senses theres a "leak" somewhere. The vent selonoid opens when a certain amount of pressure is sensed in the tank. Generally this problem will not effect how the engine runs. But will not pass some places for inspection like here in NY. I wouldnt be concerned about driving it until time and money allows for it to be fixed. A smoke machine is the fastest way to find the leak. some can just be a crack in a vent line that cannot be seen (most likely). Make sure your o-ring on your fuel cap is not all cracked, theyre common for dry rotting and allowing pressure leak causing engine light on.

    PS. Also if your in a place that salts the roads. Ive seen the secondary(overflow if you will)hose where your filler tube is crack or rot out. This would also not allow pressure buildup and turn the check engine light.
    Just some ideas good luck.




    2011 Silverado CrewCab 5.3L*Ram Air Look Cowl Induction Reflexxion Hood*6" Pro Comp Lift*Flowmaster Dual exhaust*Perfect Launch Rear Diff. Cover*Led Smoke Taillights*L.E.D.Smoke 3rd Brakelight*60" L.E.D. Tailgate Bar*Rearview Mirror Reverse Camera and Sensors*Smoke Headlight Covers*Front Bumper Grill Insert*Deezee Black Alum. Diamond Rail covers*20" Ultra Motorsports Rims wrapped with 35.5"B.F. Goodrich Tires*Inchannel Raingaurds*CAI*Bullydog GT Tuner*Alpine Amp*Boss 6x9's*Boston Acoustic Subs*Terrantula Tweeters*Custom Sub box*Red Led Interior Accents*5% Ultimacool duo tint rear window and doors, 20% front doors*Custom Vinyl Graphics*Demolded*Debadged*Painted drums and calipers*
    Future Mods Include: Custom Interior Hydrographics, Electronic Rollup Toneau Cover, 4.56 Gears, Painted rear bumper

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,353

    Default

    Sounds like the Ol' Evap.. Lots are getting that code.
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  7. #7

    Default

    Wow thanks for the help and ya it won't pass etest here and we get a lot of salt and I will check the hoses and cap and go from there and I was told if I left this problem the truck would not be good on fuel is that true

  8. #8

    Default

    A replacement valve didnt solve the problem, and testing for power at the connector showed no voltage since it didnt come on.

    I think theres an actual voltage test with a meter where you should get a specific voltage reading. The reading might not be enough to light up a basic bulb.
    If the voltage reading doesnt pass then you need to start tracing and reading the harness for breaks.
    Possibly do a continuity test on the harness to test for wire breaks.
    If that test shows no breaks then you need to test the source to find if its even sending a signal.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •