GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Turn signals do not work

    Hi, this is my first post here.

    My 1996 GMC 2500 4x4 turn signals would not work unless I got the hazard switch in exactly the right position. It worked like this for about a year, then stopped.

    I recently installed a new turn signal switch, which worked for about a day, then crapped out. Now I have nothing when I hit the turn signals. The cruise control, wipers and hazards work, but no turn signals.

    Has anyone else had this problem?

    I would replace the signal flasher, but I can't find it. I took it to a shop and they could not find it either. They said the dashboard may have to come out, as someone has done some "interesting wiring work" under there. I run a snow plow, which could be the wiring problem.

    If I could just find the flasher I could see if there is power going there.

  2. #2
    Moderator
    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Welcome to the site! There are alot of members here with 90's trucks that i'm sure can give you some advice.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  3. #3
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    It could be the circuit boards in the taillights mine went out and it took me a while to figure it out, pull out the taillight assembly at look at the board ad you should be able to see burn marks aound any of the bulbs if it is, they are pretty cheap, i got a brand new one at the junkyard for 20 bucks, the guy there said its pretty common so he stocks brand new ones reguraly
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  4. #4
    Jr. Apprentice
    Join Date
    Sep 2009
    Location
    Kingston, GA
    Posts
    14

    Default

    Quote Originally Posted by vncj96 View Post
    It could be the circuit boards in the taillights mine went out and it took me a while to figure it out, pull out the taillight assembly at look at the board ad you should be able to see burn marks aound any of the bulbs if it is, they are pretty cheap, i got a brand new one at the junkyard for 20 bucks, the guy there said its pretty common so he stocks brand new ones reguraly
    My turn signals do not work on my 90 Silverado...I replaced both tail light modules and it didn't help. One was defective preventing the back-up light from coming on so it wasn't wasted money.

    I posted the problem in the electrical forum and got alot of respones. You might check there.
    Mark
    AKA hamhock

    If you don't love your truck, it's not a Chevy...:great:

  5. #5

    Default

    I have heard that those turn signal modules can be pretty crappy from some of the after market brands. I still need to change it out in mine. A mechanic friend of mine told me that some auto companies make them for a lot cheaper, but you wind up changing them a few times.

  6. #6

    Default Problem solved

    I guess I should have followed up on that turn signal problem. It turned out to be the flasher. A simple problem, but no one coud figure out where the stupid thing was. My brother, who is a mechanic, gave up after about 15 minutes of searching and told me to take it in to the shop.

    The shop searched for about an hour (several mechanics having a stab at it) and also had no luck. They didn't charge me and apologized profusely. They told me to bring it back when they had more time to tackle it.

    I thought I was going to have to pull the whole dash out, but I went to my local dealer and they printed out a really lousy diagram that showed it buried somewhere up behind the ashtray.

    I removed the ashtray, glove box and whatever else I could yank out and lo-and-behold, it was there. It was covered in some gray foam tape. A perfect disguise. It was virtually impossible to see even if you shone a light on it. I more or less lucked into finding it by feeling around up there.

    This is absolutely the dumbest place I've ever seen to put a turn signal flasher. I don't know what they were thinking. A friend's 1996 Chevy has it right there on the fuse panel, where it should be.

    Anyway, I threw a new flasher in and everything worked fine.

    Thanks to all of you guys for your suggestions.

Similar Threads

  1. turn signals do not work on 95 z71
    By Ethan17 in forum GM Electrical Tech
    Replies: 4
    Last Post: 01-25-2010, 07:03 PM
  2. turn signals
    By vlad in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 10-06-2009, 07:07 PM
  3. are 2008 silverado work trucks pre-wired for power mirrors/turn signals??
    By george b in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 09-09-2009, 08:03 AM
  4. 96 Sub No Turn Signals
    By JersSub in forum Chevy SUV & Crossover Tech Forum
    Replies: 5
    Last Post: 07-30-2009, 12:48 PM
  5. No turn signals!
    By manifoldsrme in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 01-14-2008, 07:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •