GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 16
  1. #1

    Default What can I do with my non-responsive GM dealer?

    Hey guys,

    Hopefully someone can help me(or point me in a good direction). I'm 52 years old, and I have been a Chevy guy my whole life...I am seriously considering switching over to Ford because of my dealer.(I know!!) I'm sorry this is so long, but I
    think the backstory is important and I'm really hoping this gets forwarded to someone at GM who can get me somewhere.(PLEASE!)

    About a year ago, my wonderful wife surprised me with a used 2010 LTZ Crew(6.2L even!),52,000 miles on it, Rosen Nav/Bose combo... it was one that we had casually looked at and driven while checking dealers around town one weekend. We had driven it ONCE (the salesman had kindly 'warmed it up' for us while we were driving another one), and I of course, LOVED it. The '94 Suburban I was driving at the time had 306,000 miles on it and still drove nice, but the frame was rusting and we pull a trailer sometimes, so it was time to let her go. One day, a week later, I was sitting outside waiting for her to get home from work, and imagine my shock when she pulled up the driveway with an LTZ for me! She's just the best - she said
    she didn't want to see me underneath the Suburban anymore!

    Now, cut to the next day...I went outside to fire up my 'new' truck, and when I do, the motor is KNOCKING...for a looong time...not just the normal start-up rattle...it's a knock. When it warms up, it's mostly gone, but still louder than my 'burb w/306k on the clock, and you can hear it easily at 3000RPM. That very day we brought it back, read the sales guy the riot act, told the service guy everything, and said we wanted it fixed before we took it back. The next day, he calls me saying the guy back in the shop couldn't hear the knock!! I was like,
    'he must be deaf then', so, then I had to drive back to the dealer(two towns over), get a different service guy to agree to have a few guys out there the next morning for the cold start, hoping SOMEONE could hear it(really...it's unmistakable, and doesn't get quieter until 210 deg - even then it can still be
    heard above 3000 RPM). The next day, the new service manager I had talked to calls me and says, 'Oh, it's definitely knocking, I don't know how they didn't hear that', so then I felt like, FINALLY, they're going to take care of it.
    I should also mention, in addition to the motor issue, the Rosen Nav system, I personally believe, has a bad touch screen...here's why: When I am driving down the road, it
    will change stations all by itself...if I put it it nav mode, the station doesn't change, but the nav search mode keeps turning on and off ALL BY ITSELF. Not only is this extremely annoying, it's distracting as heck while driving. So, I had also told the service guy about this(they farm the Rosen stuff out to a local car stereo shop), he said they would send it there and have that fixed also.
    3 days later, I picked up the truck, the motor sounded quiet, and the service guy said the car stereo guy hadn't found anything wrong with the Rosen, but he had 'adjusted' it. It seemed to be working fine, so I was happy. While I was there, I talked to the motor tech that had it apart(I've built a few motors for my Camaro's over the years, I know my way around an engine), and I asked him what he found inside(they had replaced the crank, all the rods and also the pistons...NOT the the block or heads). He said he didn't really find any 'smoking gun'(his words), but #2 piston was badly scuffed and there was bearing damage on that journal and some on others also. I was feeling good about so much being replaced, figuring they had fixed it.
    WRONG. About a week later, on a 90 deg day, we came home from shopping, shut it off and brought the groceries inside. About a half hour later we decided to go out to eat, so we went outside and fired it up. HOLY HELL!!! - the motor felt like it
    was going to come out of the mounts, the truck almost disappeared in a cloud of white/blue smoke...it was bad...I shut it off, popped the hood half expecting to see something awful...nothing looked out of place, so I went to checking all the fluids(they were fine), and anything else I could think of to look at. A half hour later, I gritted my teeth and fired it up again...it was still running rough, but as it ran some more it smoothed out...guess what, the damn KNOCK WAS BACK. I was so mad at this point, I called the service guy, told him what happened, he said bring it in. When I did, he said, 'It sounds fine now' and we should 'wait and see'(his words) how it is after a few more miles are put on it...I told him I
    shouldn't have to tolerate this, and knocks don't fix themselves or get better...EVER. I think the head may have a very tiny crack near the #2 cylinder, so in the heat soak condition, it filled it partially up with coolant(or oil) and it hydraulic locked that cylinder...when I started it, I think it may have
    re-damaged everything they had fixed. The motor is no longer smooth, you can feel it pulse at a stop light now. The guys at my work now tease me about my new truck
    that knocks...every single time I start it...which of course is very maddening.
    Oh, did I also tell you the Rosen gremlin had reappeared a week or so after it was 'adjusted'? Yup. So, of course I told the service guy this also, and he said, 'Well, those units are really expensive and if it needs to be replaced, we can give you a factory unit, but that's all we can do'. NO NO NO!! I said my wife had purchased the extended warranty for this exact reason!! This truck has expensive options on it and we wanted them covered! I told him we were taking a trip soon, and he said to see how it went and bring it back then.

    I am now going to bring it back to them, anticipating a fight about everything...is this how GM really wants to support it's customers?

    I need someone to pave the road for me so I can just drop the truck off and they wil fix everything the way it should be at 60,000 miles...I'm so tired of taking work off(we only have 2 vehicles), and of this whole experience.

    Does some sort of lemon law apply here?

    Can someone from GM make(or 'encourage') my dealer to fix this?

    My dealer is Jeff Belzer in Lakeville, Minnesota.

    Thank guys for any help or ideas you can share...again sorry this post was so long...

    This was my dream truck, and it's turned into a daily disappointment.
    Last edited by lovesbikes61; 03-15-2014 at 07:16 PM. Reason: formatting

  2. #2

    Default

    Let me draw this to GM's attention, they have a rep on the site.
    @GM Customer Service
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. Thanks lovesbikes61 thanked for this post
  4. #3

    Default

    Ray, that would be great - thank you!

  5. #4

    Default

    Sounds like a lot of issues. How many miles on it when you got it?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  6. #5
    Jr. Engineer Cowpie's Avatar
    Join Date
    Jun 2013
    Location
    Central Iowa
    Posts
    216

    Default

    My first thought regarding the title of the thread was to provide the dealer name and address to a terrorist cell and let them take care of your problem for you! Just me and my weird mind. I'm old.
    Hey there, VA, what do ya' say? How many vets did you kill today?

  7. #6

    Default

    As I said in the 2nd paragraph, 52,000...the truck is in great condition overall...

    - - - Updated - - -

    still funny...I'm old too...

    Oh, service also said they were doing us a 'favor' by having the Rosen system looked at...when the warranty sales guy told my wife it was completely covered.

  8. #7
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    Did you get a Carfax on it?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  9. #8
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,468

    Default

    you purchased this one year ago ? you say the day after you purchased this the engine made loud noises ? then you brought the vehicle back to dealer to be checked out , then days later they repaired the engine after your purchase. then you found that the repair was not correcting the noise issues ..

    so it is one year after you purchased this vehicle is that correct ? just trying to figure out the time line and how you have had this one year and you still have these continuing issues from the first day of ownership.

  10. #9

    Default

    Go to another dealership.

  11. #10

    Default

    A dtream to a nightmare. I'll be honest. Pray! Its just not that dealer or this brand (Chevy). Theres a story like this for every brand and dealer. Best advice. Persistent and polite.

    2008 Purple LTZ Crew Cab

Page 1 of 2 12 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •