GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Superchip 2815 help please!!

    So, first off I got a 2005 z71 last night. First z71 I've had. And I love it. It's awesome. Okay now. My question is, how in the world do I get my programmer to work? I plugged it in and it doesn't come on. Tried with truck off, truck on, truck cranked. Idk what it's problem is, it won't come on. It was set up for gas mileage, but like most people. I wanna play with it and see what it'll do. So is there a truck to getting it to come on? I heard something about a fuse being blown and the way I could tell is a cigarette lighter plug wouldn't work, and the passenger side one doesn't. Anyone got any help for me? Also, here's a pic of my truck for those who wanna see it.


  2. #2

    Default

    Nice Truck! Welcome aboard! You should try contacting, Superchips tech help. Good luck.
    2010 GMC SIERRA CREW CAB (Silver) 4x4, ReadyLift 2.5" Level Kit, 305/60/18 Dick Cepek Mud Country, Go Rhino Nerf Bars, Husky Liners front and rear, Bushwacker Bed Rail Caps, Custom tuned. 4:11's

  3. #3
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,360

    Default

    Is it a new programer? Something you had for a past truck?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  4. #4

  5. #5
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,360

    Default

    could be a fuse Do to a Autoparts store and let them try to read your truck.. See what happens..

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,481

    Default

    check all the fuses .. not exactly sure which one feeds the dash power sockets. could be cig fuse.

    if these sockets have no power then the dtc obdII connector will be dead no power..

  7. #7

    Default

    Alright. Appreciate the help guys

  8. #8

    Default

    It was a fuse. Got it fixed. Thanks for the help everyone

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •