GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Sr. Apprentice
    Join Date
    Mar 2014
    Location
    Pikeville kentucky
    Posts
    53

    Default Some kind of problem???

    Can anyone tell me what this is?

    is it the thing for remote start?


    anyways. When I popes my hood I saw this thing covered in something, not sure if it was oil or power steering fluid

    checked the oil and it was perfect. Checked the power steering fluid and it looked a bit low




    does anyone know what this could be
    every time I start the truck it smokes a bit. It's a white smoke. Only last for about 2 to 4 minutes and then goes away.
    I know I have a wheel bearing going out, could this have something to do with it

    seems like I have had nothing but problems since I've bought this truck in October of last year

    its a 2007 LT avalanche with 120,000 miles on it

    any help would be great. Thanks
    Attached Thumbnails Attached Thumbnails image.jpg  

  2. #2

    Default

    that is your steering shaft. it goes from your steering wheel to your gear box (on 4x4 models) or the rack and pinion (2wd models). The wheel bearing going out has nothing to do with white smoke. If it is cold where you live it is normal to have a visible exhaust at start up.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  3. #3
    Sr. Apprentice
    Join Date
    Mar 2014
    Location
    Pikeville kentucky
    Posts
    53

    Default

    It has been cold. But it still smokes white when it's about 60 degrees outside. And it kind of smells like something is being burnt. But again. All fluids check out fine.

    Any idea why the steering shaft could be covered in some kind of fluid?
    Could it be power steering pump problems?

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,362

    Default

    Check your Oil Again There has been some Problems with the Great AF%M 5.3's...and bearings too... GM Cheap crap from China..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  5. #5
    Sr. Apprentice
    Join Date
    Mar 2014
    Location
    Pikeville kentucky
    Posts
    53

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    Check your Oil Again There has been some Problems with the Great AF%M 5.3's...and bearings too... GM Cheap crap from China..
    Yea, I've been reading about it on here. But I don't think that's what's wrong with mine. I have no engine light on and the truck runs great still. It's been smoking white at start up for a little over a month now. Went and checked the oil, it's perfect. Coolant is fine. Only thing that was low a bit was the power steering fluid.

    Gonna test the coolant tomorrow. I read that I should take the cap off and rev the engine a bit, if there's bubbles, I could have a blown head gasket. But if that was the case, wouldn't I be low on antifreeze

    also read that the valve seals and guides could cause white smoke at start up. Do you all think that's worth checking into, or a waste of time?

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,362

    Default

    Mine did it at start u and when ever the truck went from 4 back to 8 Cyl I saw out my back window..

  7. #7
    Sr. Apprentice
    Join Date
    Mar 2014
    Location
    Pikeville kentucky
    Posts
    53

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    Mine did it at start u and when ever the truck went from 4 back to 8 Cyl I saw out my back window..
    What was causing yours to do that

  8. #8
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,362

    Default

    The AFM Problem Oil Consumption..

  9. #9
    Sr. Apprentice
    Join Date
    Mar 2014
    Location
    Pikeville kentucky
    Posts
    53

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    The AFM Problem Oil Consumption..
    Yours was using oil though. Right?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •