GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2

Thread: Mystery?

  1. #1

    Default Mystery?

    My battery died on me, so I took it off and a couple of days later I replaced it. It started up instantly, although the tick over was slow, but picked up. Next day I started up again and was resetting my Radio/Satnav/Bluetooth unit with the engine running, after a while I switched to aux to save petrol, after setting it up I went in home for a coffee, came back and I could not start the vehicle, it cranked over beautifully, tried the security thing with the ignition on for 10 mins nothing, in the end I wondered if the petrol gauge was wrong, (was reading 1/3 full) I put two gallons in, it started instantly, no cranking? Next day filled up could only get 10 gallons in, so I had not ran out of juice. No problems since. In fact it feels more responsive. Any Ideas? Gus.UK. 2002 Suburban LT
    Keep Rockin'
    Gus:great:

  2. #2

    Default

    Well, at a quick glance, it might be, as you suspect, fuel problems.

    Let it sit for awhile and have someone turn the key to RUN (don't try to start it)while you stand by the rear wheel, see if you can hear the fuel pump running.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. Thanks gustheiceman thanked for this post

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •