GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Default Need some Help!! Escalade EXT cranks but wont start!!

    Ok one day going to work.. i got the low fuel indicator.. went and got some gas.. after leaving the gas station on the first stop.. i got the stabilitrak service and service traction control.. the truck started to idle really bad.. misfiring like crazy.. check engine light was blinking (im pretty sure thats safe mode or reducing power) lost alot of power.. well the only thing to make the car run was put it in neutral and rev it to stop it from misfiring.. i barely made it to work i parked it.. it started normally.. first thing i did was put a can of seafom and some iso heat.. i thought i had bad gas.. everything i went to the car i could start the car and will idle bad.. well i continued with my shift.. and i ask some guy with his scanner to come.. we checked and i got a p0171 and p0300 so thats a system to lean and multiple misfires.. sounds like bad gas to me dont you think??? anyways.. the truck could be started normally.. my stupid friend.. cleared the codes.. after he cleared the codes.. the truck will crank but wont start... the truck has to be towed.. i felt really sad because this truck was expensive and i have an 04 tahoe and i had 0 problems with it.. and this truck i had problems from the first time i got it..

    anyways i did alot of research online.. so my first thing i did was check fuel pressure.. and i checked it.. and BAM!!! fuel pressure was really low.. like 40s psi.. and it will drop really fast.. so we changed the FUEL PUMP.. after we changed the fuel pump we check the pressure and BAM 50psi no matter what and it will hold the pressure..

    so we tried to start the car and NOTHING same as it wasn't installed.. DUDE i wanted to cry thats messed up!!!

    anyways did more research... so i took the throttle body and the maf.. and cleaned the **** out of it with special cleaner.. put it back and still nothing..
    next step changed the crankshaft sensor.. still NOTHING.. only starts with starting fluid.. so last resort changed the camshaft sensor and the camshaft actuator magnet..

    i was so happy because i knew this was gonna work.. so i tried it and NOTHING!!! car cranks but wont start..

    guys idk what to do im losing of ideas.. i want to towed it and take it to the dealer but some personal reasons happened so im really short on money at the moment.. I dont know what to do..

    so i know theres fuel pressure and starts with starting fluid.. so something is stopping the injectors from starting.. i tried to check wiring harness everything is good.. should i change the ecm?? i just need to fix it ASAP..

    any help guys??

    By the way when we changed the fuel pump i still got like less than quarter of gas.. same gas as the one i got from the gas stationg.. u think thats the problem\?

    Things changed:
    Cleaned MAF & Throttle Body
    Replaced Crankshaft sensor, Camshaft sensor & Camshaft actuator Magnet
    Replaced fuel pump( did pressure test and is at 50Psi)

  2. #2

    Default

    Welcom to the club!! Sorry to hear about all the problems you had with your Escalade EXT. I had an 03 Ext and it was the worst GM vehicle I had ever owned. I didnt have the problems that your having with the engine but just about everything else went bad on it. The one thing you should check is make sure 50 psi is enough pressure to start the truck.. Even a new fuel pump could be bad and not give enough pressure to start. I thought the pressure needed to be in the mid 60's to start and could be less pressure to run. But I could be wrong. Good luck and I hope you get it figured out.




    2011 Silverado CrewCab 5.3L*Ram Air Look Cowl Induction Reflexxion Hood*6" Pro Comp Lift*Flowmaster Dual exhaust*Perfect Launch Rear Diff. Cover*Led Smoke Taillights*L.E.D.Smoke 3rd Brakelight*60" L.E.D. Tailgate Bar*Rearview Mirror Reverse Camera and Sensors*Smoke Headlight Covers*Front Bumper Grill Insert*Deezee Black Alum. Diamond Rail covers*20" Ultra Motorsports Rims wrapped with 35.5"B.F. Goodrich Tires*Inchannel Raingaurds*CAI*Bullydog GT Tuner*Alpine Amp*Boss 6x9's*Boston Acoustic Subs*Terrantula Tweeters*Custom Sub box*Red Led Interior Accents*5% Ultimacool duo tint rear window and doors, 20% front doors*Custom Vinyl Graphics*Demolded*Debadged*Painted drums and calipers*
    Future Mods Include: Custom Interior Hydrographics, Electronic Rollup Toneau Cover, 4.56 Gears, Painted rear bumper

  3. #3

    Default

    Quote Originally Posted by zpeedy88 View Post
    any help guys??
    Vehicle info would help us!!!!!!!!

    I'm guessing, it's an '07, or newer EXT. If it is, there is a fuel pressure module under the truck, mounted above the spare tire.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4

    Default

    i read the manual and looks like is 50psi i might be wrong tho.. but yeah i had problems with this truck since the day i got it.. the 04 tahoe is just been superb...

  5. #5
    Jr. Engineer
    Join Date
    Oct 2013
    Location
    weedsport, NY
    Posts
    212

    Default

    you changed the pump, but did you change the filter too? 50 psi sure does sound low! If it will fire up with starter fluid, then its a fuel problem, I'd be for checking the fuel pressure module too, as per ray voy!

  6. #6

    Default

    on these trucks.. the filter regulator and sending unit is built into the pump.. i know the pump module in front of the spare just controls the pump on and off.. so you guys think i got me a defective pump?

  7. #7

    Default

    Quote Originally Posted by zpeedy88 View Post
    on these trucks.. the filter regulator and sending unit is built into the pump.. i know the pump module in front of the spare just controls the pump on and off.. so you guys think i got me a defective pump?
    I would try and search to find out what pressure is required before going and doing that job again.. But like @zuki82 said it does sound a little low. My GMC jimmy I had required like a minimum of 63 psi to start and like 55 psi to run. But were talking 2 totally different engines also. Maybe call the dealership and if theyre nice they might tell you what it should be.

  8. #8

    Default

    lol the dealerships around here are dicks lol

  9. #9

    Default

    I am pretty sure 50 psi is normal if it is a e85 vehicle. did you change the fuel pump electric connector also? it you solder it in? what brand pump did you purchase? please don't say airtech.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  10. #10

    Default

    Quote Originally Posted by zpeedy88 View Post
    i know the pump module in front of the spare just controls the pump on and off..
    If the module just controlled the pump on/off, they would have continued to use a relay mounted in the fuse panel. Why would anyone replace a switch with an electronic module unless more was required that just a 1, or a 0.

    I think you will find the module turns the pump on and off and that it also controls the pressure being pumped.

Page 1 of 2 12 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •