GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1
    Sr. Apprentice
    Join Date
    Nov 2013
    Location
    Alliance,Ohio
    Posts
    64

    Default Distributor magnetic pickup

    Working on 98 4.3 after replacing a coil with no resistance I have a hard start issue and a pretty noticble mis. I leaning toward an issue with the pick up under the rotor? anyone with testing info would be great!
    1998 1500 w/t short bed 4.3

  2. #2
    Jr. Engineer
    Join Date
    Oct 2013
    Location
    weedsport, NY
    Posts
    212

    Default

    HUMMMM,, Not much to go on there! Give it a total tune up first, then see! When running, grab the three wires coming out of the bottom of the dizzy and move them around. If it falters or dies, then you have your problem! It could be soooo many things, give it a tune up first !

  3. #3

    Default

    Ok, the obvious question, to me, is why did you check the resistance of the coil?

    Were you having a problem trying to start before you tested the coil?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4
    Sr. Apprentice
    Join Date
    Nov 2013
    Location
    Alliance,Ohio
    Posts
    64

    Default

    Yes! pulled it out of the garage to work on the son's car and when I was done and ready to pull it back in no start issue tested the coil after fuel pressure and spark and that's where I noticed the weak yellow spark. At that point is where the resistance test on the coil came about along with testing of the all the wires, cap and rotor. Now I'm just going through the process of elimination. Since this transpired I have unplugged the TPS and the miss has stopped haven't tested the TPS yet waiting for daylight to check for a dead spot in the field. I have yet to rule this the solution without further testing of the other systems in the loop I do not believe in parts changing without just cause.

  5. #5

    Default

    Not sure I understand how the TPS could cause a mis-fire, a flat stop maybe, a timing change maybe. Does the '98 have a throttle cable?

  6. #6
    Sr. Apprentice
    Join Date
    Nov 2013
    Location
    Alliance,Ohio
    Posts
    64

    Default

    Yes it does (have a throttle cable ) and the result of a flat spot in the field of the tps would tell the pcm to back off the fuel pressure which in turn results in a mis-fire. Like a small electrical short in the system if I understand the system correctly. This the last year of the C series that is drive time data unable through the OBD11.

  7. #7
    Jr. Engineer
    Join Date
    Oct 2013
    Location
    weedsport, NY
    Posts
    212

    Default

    Boy Howdy!! You swung that cat all the way around, HUH! LOL! I wanna know , how does the TPS affect the weak spark? You had a "no start" situation, and now ,here we are, at the TPS! I think a bad coil will cuase a miss fire too.

    - - - Updated - - -

    OK, My bad! I went back thru and reread it, AGAIN! Think I'm on track now!

    time to ponder!

  8. #8
    Sr. Apprentice
    Join Date
    Nov 2013
    Location
    Alliance,Ohio
    Posts
    64

    Default

    Man you had me going being a slow reader but. I do like to troubleshoot and not just through parts at issues without proving them out. The missfire disease has allot of variables!!!!!!!!

  9. #9
    Jr. Engineer
    Join Date
    Oct 2013
    Location
    weedsport, NY
    Posts
    212

    Default

    Well, then, first I wanna say welcome aboard! Second, I'll be coming to you when I have problems! I generally don't have a lot of time to do a lot of testing! Now that spring is here, I can let the truck sit while I ride the bike to work and back, get some things fixed up and ready for next winter!

  10. #10
    Sr. Apprentice
    Join Date
    Nov 2013
    Location
    Alliance,Ohio
    Posts
    64

    Default

    I'll help when I can. But to be totally honest I have learned all my testing proceedures from being a boat owner for over 20yrs and researching the net and y-tube's scanneir danner (he's a geniuess) with diagnostics. But more to my point I keep experiencing a steady miss when it rains this morning my ride to work was very frustrating which is leading me to a short of some sort which can be a very time consuming process which I'm not looking forward to.

Page 1 of 2 12 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •