GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default new here, seeking help with dash problem!

    Hello, my name is Ryan. I am new here I have a 2008 GMC Sierra that i am having some unknown issues with today. I bought the truck about 6 months ago and it has been a great rig. however this morning i got up to get to work and the speedometer wasnt working, the shift indicator wasnt working, the volt gauge read high, the oil pressure read high, the temp guage never moved, and the air bag light was on. truck drove fine besides all of that. a co-worker of mine said i have to replace the guage cluster but i do not know if that is true, anyone else have this happen or know what to do to fix it? Thank you much!!

  2. #2

    Default

    Hey there RThompson,

    I understand that you are looking for technical advice from your fellow forum members. As a customer service representative, I'm not able to provide much in the way of do-it-yourself information, so I'm glad to see forum members are beginning to step in with feedback. If you have any lingering concerns please contact me via private message.

    Jennifer T.
    GM Customer Care

  3. #3

    Default

    went out and drove it again, everything was fine. this is probly going to be a intermittent problem. still if any one knows what it may be i sure would appreciate the help!

  4. #4

    Default

    I repaired my 2003 dash cluster by adding new stepper motors. No problem. When I got the dash apart to solder in the new motors the very small switch the resets the trip meter feel apart on the table. That explains why it quit working. Does anyone know the part number of that very small electronic switch? I can solder it in, I just need to understand where I can get one.

  5. #5

    Default

    My father had the same problem on his 03' silverado. There happen to be a recall for that issue. I would look to see if your truck has a recall for that issue or if it an issue that the dealers know about and will fix for free.
    Chevy Coastie. 2010 Silverado Crew Cab. 20" Rims, 6000k Kelvin HIDs, Kelvin LED Dome lights, 20% tints

  6. #6

    Default

    Quote Originally Posted by Chevycoastie View Post
    My father had the same problem on his 03' silverado. There happen to be a recall for that issue. I would look to see if your truck has a recall for that issue or if it an issue that the dealers know about and will fix for free.
    This Issue/Problem with The Stepper Motor's on the 2003" to 2006" Trucks-n-SUV" Dash Cluster's, sorry to say, it wasn't a recall, it was a Special Coverage Adjustment, the link below goes into detail regarding this Special Cover Adjustment,

    Link,
    http://www.gmspeedometerrecall.com/g...ter-settlement


    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  7. #7

    Default

    thank you for the correction. I was only going off what we were told from the dealer.

  8. #8

    Default

    Sounds like it could be a ground problem.

    I have no idea where they are, but things like the dash will have ground strap(s), sounds like one is lose/dirty.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    Check out this guy. I found this elsewhere in the forums.
    Dr.Speedometer.com

  10. #10

Page 1 of 2 12 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •