GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Doesn't like being warm.....

    Hey guys..been a while. truk is running good except for this "new" quirk. After a 20 min/mile drive,(on an already warm day) I turn truk off and when i go to restart it say 5-10 min later she no start?

    I know the IAC is new (when it was rebuilt)

    95 5.7 TBI with less than 3000 miles on reman engine.
    Blank slate....work in progress....
    95 Chevy 5.7L 2wd...no mods..yet
    Resto project.

  2. #2

    Default

    Assuming the engine turns over, then I would check for spark. Could be a heat sensitive ign module.

  3. #3

    Default

    Quote Originally Posted by silverado002 View Post
    Assuming the engine turns over. Could be a heat sensitive ign module.
    Or perhaps a heat sensitive fuel problem.

    Now, if there is no crank, then you probably have a starter problem.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4

    Default

    Quote Originally Posted by silverado002 View Post
    Assuming the engine turns over, then I would check for spark. Could be a heat sensitive ign module.
    Yea it turns fine. just when i drive about 20 to 25 miles on a "warm" day it gives me fits starting.

    - - - Updated - - -

    Quote Originally Posted by RayVoy View Post
    Or perhaps a heat sensitive fuel problem.

    Now, if there is no crank, then you probably have a starter problem.
    Cranks fine. starter is good. IF I let it sit for 20 min i can get it to start...may take 5 or 6 tries but it does.

  5. #5

    Default

    Still having the "warm starting issue". It has now developed into acting like its missing in the morning as i am pulling out of the driveway. (Ignition module?). It goes away as i get farther down the road. On my way to work when I am stopped at an intersection..it will randomly die. Idle seems a bit low to at times but that is ECM controlled.

    I am getting ready to rebuild the TBI this weekend cuz it was the only item that wasn't rebuilt when i put the engine in...not sure why i didn't!? So I am gonna buy the gasket kit and either the ignition module or the TPS and cap and rotor. ECM may come later dunno yet.

    Ideas...advice...always welcome.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •