GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Thread: engine misfire

  1. #1

    Default engine misfire

    So out of the blue my 05 equinox starts to have a garggling sound as if my cat is gutted. I pop the hood to hear a clicking coming from what looks like the distribution block ( all the spark plugs wires are plugged into this). I run the codes and get a engine missfire, and generator lamp control circuit. I call cheavy to try and order this distribution block and they dont know what Im talking about (they can only run by codes). I give them the codes and the service tech tells me the generator lamp is in the alternator. Alternator is 538. I order the alternator change it only to see no improvements. My car is still misfiring. I cant find out the name of this part anywhere at all and honestly don't now where to go from here.

    car garggles and hesitates at low rpms (under 3k)

    anything above that car drives fine.

    engine code p300, p0621.

    any help is greatly appreciated. My warranty is up so I'm in this alone and with the terrible help Im getting from chevy I don't know where to turn.

  2. #2

    Default

    is this the same mr sig i know?

  3. #3

    Default

    Sorry about the delay.

    Just for update

    I changed the alternator (dealer solution for the error code) and no go. Still the same issue. I called Chevrolet and they told me to take the car into the dealer and they will assist in getting the problem solved. That's fine but one thing remains, all of this is at my expense. I trusted their service and spent 500 dollars for nothing.


    The truck has finally given up. It cranks and if I tap the gas it sounds as if it wants to turn over but then it makes a clunking noise and shuts off. I hate to bite the bullet but I guess I'm going to be stuck with one hell of a bill from chevy. The cars traction light came on and vehicle slowed to a stop.

    I am purchasing and new generator control circuit Monday and will change it and see what happens. Will keep posting with any finds I have that might be able to help anyone else.
    Last edited by Mr.sig; 11-09-2008 at 02:59 PM.

  4. #4
    Legend tlperry68's Avatar
    Join Date
    Oct 2008
    Location
    Huntington Beach, CA
    Posts
    1,504

    Default

    How do the plugs look?
    Trevor - Huntington Beach, CA
    2007 GMC 2500 4X4

  5. #5

    Default Misfires

    What can cause engine misfires???? I recently heard that bad and or broken plug wires can cause this..
    Last edited by Mr.sig; 11-09-2008 at 04:41 AM.

  6. #6

    Default

    Quote Originally Posted by tlperry68 View Post
    How do the plugs look?

    the plugs looked pretty clean I changed them that last time I tried to sort these issues out. Insurance company will pick the car up tomorrow sometime and tow it to my home.

    I will take pics of the plugs and cyl 4 (that has the misfire).

  7. #7

    Default

    I brainstormed for a few hours and wrote down my plan. I checked the fuel first and bingo. No fuel going into the rail at all so that says fuel pump. I am getting spark at all the plugs and after speaking to a friend of mine that works in chevy service he says that bad fuel pressure and cause the misfire.


    I now have to drop the tank or see if I cant actually change the pump from the inside of the car. Can anyone tell me if the Fuel Tank Module Pump SENDING UNIT is the same as the fuel pump???

    to answer my own question. The car has two fuel pumps. a primary and auxillary pump. I have found a few aux pumps all use and some other places that are selling pumps also.

    I will be getting a scan tool from a friend tomorrow to try and prime the fuel pumps through that. If that dosent work then I will be ordering the new pumps come tuesday.

    MY guess is the fuel pump gave out and aux kicked in. Auxillary finally gave out friday as it isn't designed to last long..
    Last edited by Mr.sig; 11-09-2008 at 02:58 PM.

  8. #8

    Default

    update


    got the service scanner from chevy and at the same time got a snap on scanner to compare codes.

    snap on scanner threw 4 codes one of which was the p300 engine misfire code.

    Chevrolet scanner threw 16 codes.

    with that I was able to try and manually prime the pum which didn't work


    long story short the pump had a short. fixed it and car started with the misfire.

    the misfire was cause by a melted rubber in the the actual spark plug socket blocking the the firing area.


    changed the wires and got rid of 15 codes. Did a complete service on the car with plugs wires gaskets and a few other minor things...


    car use to give starting issues now starts up one crank and runs like a charm!!


    thanks for everyone's help.

Similar Threads

  1. still have misfire help please
    By cable734 in forum GM Powertrain
    Replies: 6
    Last Post: 05-16-2011, 08:39 AM
  2. Engine misfire
    By gmcman101 in forum Chevy C/K Truck Forum
    Replies: 13
    Last Post: 11-03-2008, 11:35 AM
  3. Misfire
    By OkieMike in forum GM Powertrain
    Replies: 2
    Last Post: 03-04-2008, 06:43 AM
  4. Misfire
    By KingDNH in forum GM Powertrain
    Replies: 4
    Last Post: 02-13-2008, 02:23 PM
  5. Chevy check engine light for misfire
    By GeoK in forum GM Powertrain
    Replies: 1
    Last Post: 12-22-2007, 11:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •