GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: Crank sensor

  1. #1

    Default Crank sensor

    A while back I posted a problem with my truck shutting off while driving. Finally figured out it was a bad crank position sensor. Just to let yall know, if you have a similar problem.
    I dont care how you did it in California!!!:biggrin:

  2. #2

    Default

    Since 90% of a problem can be diagnosis, can you be more specific as to how you determined the CKP was at fault?
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  3. #3

    Default

    Tookit chevy dealership, paid $90. and they hooked it up to their diagnostic computer.

  4. #4
    Moderator

    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Glad the problem was found that easy.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  5. #5
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Original post/problem, for future reference:


    Quote Originally Posted by Wolfinthesnow454 View Post
    Hello, everyone, new here. First I want to compliment everyone on the nice site and their expertise on these trucks. Very well done!!

    Second, I need your help.

    This has been a reoccuring issue with my truck. (2002 silverado 2500HD with the 8.1 in it)

    I will be driving down the interstate about 70mph-ish when the engine completely dies. No problems on the message center, everything works on the dash, RPMs are at 0, and now im coasting. Several hundred yards later, engine starts back up on its own. I dont even have to turn the key.
    Well today I was sitting still in traffic and it shut off on me again. At a dead stop. It would crank over, but not start. Ran the battery dead trying to crank it. My dad came to help, charged the battery, and it started right up.

    It sounds wierd but this is what its doing. I do know that the engine is completely shut down and now it shuts off while sitting at an idle, but it gives no warning.This only happens once every 2 weeks or so. Running fine, then dead. But will start later with no issues?? Doesnt make sense.
    Anyhow, anyone have this problem before? Or atleast know what it may be?
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




Similar Threads

  1. CRANK POSITION SENSOR chevrolet SILVERADO 1500 part
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 06-12-2010, 04:51 AM
  2. where is my crank position sensor?
    By HI-TORQ in forum GM Powertrain
    Replies: 1
    Last: 05-19-2010, 09:26 PM
  3. CRANK POSITION SENSOR chevrolet SILVERADO 3500 part
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 03-14-2010, 08:10 PM
  4. CRANK POSITION SENSOR chevrolet SILVERADO 3500 part
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 02-06-2010, 11:10 PM
  5. 04' Crank sensor?
    By PencilPro in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 01-31-2010, 01:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •