GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9

Thread: obd2 problems

  1. #1

    Exclamation obd2 problems

    I have a 2003 silverado 2500 4x4 with a 6.0 liter engine in it I bought it used. It has magnaflow exhaust on it. Im having problems with the obd2 port. I have a genysis scan tool which is top of the line right now but i when i hook it to my truck it says it does not have a connection and it does it with every other scan tool i hook to it also. Ive checked all the fuses and non of them are blown. Can someone help me out please? I have no check engine lights on but i want to get it fixed because i want to put a superchips cortex programmer on it

  2. #2
    Moderator

    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Welcome to the site! We have a few members here with some knowledge on that sort of this so i'm sure they well reply soon.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  3. #3

    Default

    The usual reason for that behavior is no power to the diagnostic port: usually a blown fuse. If you are certain all of the fuses are good (it seems that it's usually a cigarette lighter or accessory power fuse), then I'd get a wiring diagram and figure out if the diagnostic port has power.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  4. #4
    Master Mechanic CarpenterGuy's Avatar
    Join Date
    Jul 2008
    Location
    Leeds, Alabama
    Posts
    994

    Default

    Roll Tide!!!
    2006 Silverado Z71 - 97,000 - totaled, RIP
    2006 Silverado Z71 - 122,000 (K&N 77 Series CAI, PowerAid TBS, Magnaflow dual rear exit, 33x12.50 Mickey Thompson MTZ, Tuff Country Torsion Keys, Tuff Country Add-A-Leafs)
    1966 C10 swb stepside (Gen I 350, Turbo 400 trans, dual cyl power brakes, front discs)
    I'll keep my money, guns, and freedom. You keep the Change.

  5. #5

    Default

    Man I preciate your help mr.shorty and ROLL TIDE TO YOU 2 CARPENTER!!!!!!!!!!!!!!!!!!!!!!!!!!! THEM BOYS LOOK GOOD THIS YEAR DONT THEY?!

  6. #6

    Default

    Quote Originally Posted by 4x4CountryBoy2500 View Post
    I have a 2003 silverado 2500 4x4 with a 6.0 liter engine in it I bought it used. It has magnaflow exhaust on it. Im having problems with the obd2 port. I have a genysis scan tool which is top of the line right now but i when i hook it to my truck it says it does not have a connection and it does it with every other scan tool i hook to it also. Ive checked all the fuses and non of them are blown. Can someone help me out please? I have no check engine lights on but i want to get it fixed because i want to put a superchips cortex programmer on it
    Hi, Did you ever get your Diagnostic Port to work ? .... I having the exact same problem with a Hypertech Max Energy Programmer i just bought .... no display what-so-ever ... the fuses in the dash (left side of steering column) are good .... Is it a fuse under the hood ? ..... i have a 2003 Silverado 1500 Z71 5.3L

    Thanks for any help,

  7. #7
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    not to start a fight or anything, but ummm...


    TIGER BAIT!
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  8. #8
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default

    welcome to the club
    2000 silverado with a 5.3l v8, shorty headers, upgraded plugs, 10 mil wires, magnaflow high flow cats, flowmaster 80 series muffler(2 in 2 out) w/ 18 inch stainless silverline tips. i have a k&n CIA. its a 4x4 z71 offroad package. Ls model.
    extended cab 160k miles, truxedo low profile bed cover, diablo sport predator tuner.
    reman tranny @ 130k miles
    Chris

  9. #9

    Default Diagnostic Port is Working Now !!!

    Quote Originally Posted by cascott325 View Post
    welcome to the club
    Thanks, Awesome Forum ...... BTW, i got my Diagnostic Port Working for my Max Energy Hypertech, there were 2 fuses out in the Fuse Box under the hood, a Cig Lighter & SEO fuse were blown .... i replaced them and my Diagnostic Port started working ..... which is kinda funny because my Cig. Lighter was working with that fuse blown.
    " Bow Tie Till I Die "

    2003 Silverado Z71 1500 5.3L, K&N CAI Intake, FlowMaster American Thunder, Max Energy Hypertech, 6 in. SuperLift (Bracket Style), 20 in. Mazzi Hulks, 33 in. Open Country M/T, High Capacity Polished Rear-end Cover, Royal Purple Fluid Rear-End Fluid, Mobile 1 Motor Oil, Kenwood 7100 Deck, Rear-View Camera

    1978 Blazer, 6 in. Skyjacker Lift, 36X13.50-16 Iroks, Black Steel Simulated Bead Lock Rims, SB 400 .... currently looking for DANA 60 front & 14-Bolt rear Axles


Similar Threads

  1. obd2 codes throwing me off
    By greasemonkey in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 02-28-2010, 01:46 PM
  2. 4wd problems.
    By 95Chevyk1500 in forum GM Powertrain
    Replies: 2
    Last: 12-10-2009, 01:05 PM
  3. Help with P0146 OBD2 code, please!
    By latina.paul in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 8
    Last: 08-18-2009, 11:02 AM
  4. OBD2 problem
    By hayking in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 04-27-2008, 03:41 PM
  5. Chevy Silverado Heater problems blower problems
    By bidutch in forum GM Powertrain
    Replies: 3
    Last: 12-13-2007, 05:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •