GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: Charging issue

  1. #1
    Jr. Mechanic
    Join Date
    Jul 2008
    Location
    Bluegrass Country
    Posts
    112

    Default Charging issue

    I have an 03 chevy silverado. 4 months ago, I replaced the battery, this past weekend the alternator crapped out. I replaced the alternator and now the charging light in the dash stays on. I've checked the battery with a multimeter and I'm getting 14.6 volts to the battery while running and the same at the alternator. Why would the charging light stay on? Anyone have a clue?

  2. #2
    Legend tlperry68's Avatar
    Join Date
    Oct 2008
    Location
    Huntington Beach, CA
    Posts
    1,504

    Default

    Is there a solenoid between the altenator and the battery? That might be the problem. Other than that I really don't know.
    Trevor - Huntington Beach, CA
    2007 GMC 2500 4X4

  3. #3

    Default

    Does the light go out when you raise the idle? Most likey the gauge is bad.

  4. #4
    Sr. Mechanic raisor87's Avatar
    Join Date
    Jul 2008
    Location
    the nasti nati
    Posts
    190
    Blog Entries
    2

    Default

    disconnect the battery for 10 minutes, or just drive it your pcm can take a while to reprogram itsself or bad voltage regulator ?
    1998 GMC Sierra SLE- Bone stock engine, 4'' in dash dvd 2 10" subs 800watt amp.

    1999 Buick Park avesdf

    1971 Buick Electra 225 built 455 and turbo 400

  5. #5
    Jr. Mechanic
    Join Date
    Jul 2008
    Location
    Bluegrass Country
    Posts
    112

    Default

    Light doesn't change with idle, I've took the alternator back to NAPA and had it tested. They said it was good. I'll try the battery disconnect and see what happens. Thanks

  6. #6

    Angry

    try Replacing the battery, in my 96 Tahoe i was going bazerk, so i replaces all the electrical and it still was goin crazy, batter seemed fined, untill i was going up a hill and the engine starts to cut out, THE BATTERY WAS FRIED, it turned out that the battery malfunctioned, but still showed Volts and amp, i replaced it. totally fixed the problem. i put out a bunch of money just for a damn 70$ batter. that suked ,

Similar Threads

  1. charging issues
    By kb7586 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 02-16-2010, 09:48 PM
  2. a/c charging to cold
    By pewterburb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 10-12-2009, 10:00 AM
  3. super charging
    By BBCCARGUY in forum GM Powertrain
    Replies: 10
    Last Post: 08-15-2009, 01:57 PM
  4. Help!!! Charging system!!!
    By pmf608 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 01-07-2009, 08:28 PM
  5. Help!!! Charging system!!!
    By pmf608 in forum Audio, Video & Gadget Tech
    Replies: 2
    Last Post: 01-07-2009, 06:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •