GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 14

Hybrid View

  1. #1

    Default Whats wrong w/my Gas Gauge

    [media]http://www.youtube.com/watch?v=e03D6baZekA[/media]

    Sender or dash gauge??

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    pic wont load, so am gonna give ya what i know, if its fluttering back and forth constantly then its the gauge. if you dont have seperate guges from one to the ohter then you have to replace the entire cluster
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Dash gauge. Tough to tell on the video.... is it twitching real fast while it reads like that? If it's just the bouncing up and down it may very well be the sending unit.

    As much as I hate being one of those people... do a search on the forum and you will find oodles of posts regarding the messed up fuel gauge. Depending on what year your vehicle is.. (it looks to be around.. '99?) you can bring your vehicle into GM for a recall. I think it's 03-06 for the recalls.

    But welcome to the world of bad GM clusters if you got a twitchin' gauge!
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  4. #4

    Default

    I've never saw a gauge go bad in the 20 years plus working on cars. Replace the sending unit.

  5. #5
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    well then i should have sent you mine, it fluttered like a hummingbird wing, replaced the cluster and no problems since 04

  6. #6
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    And there are entirely WAY too many posts about bad gauges in here to not notice it being a problem.

    vnc, did you have the gauge replaced at the dealership with a new one?

  7. #7
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    sure did, I brought it in and they tested it and since I bought a new one with them they waived the testing fees so i was pretty happy.

Similar Threads

  1. Did I do something wrong??
    By blackburb in forum Lifted & Offroad Suspension
    Replies: 7
    Last: 09-21-2009, 08:59 PM
  2. Whats wrong here?
    By no0b123 in forum Audio, Video & Gadget Tech
    Replies: 13
    Last: 10-22-2008, 12:37 AM
  3. wrong oil
    By billw in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 03-09-2008, 11:31 AM
  4. what am i doing wrong?
    By 89suburban350 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 05-21-2007, 02:14 PM
  5. fuel gauge sticks in wrong position
    By ghilligoss in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last: 06-24-2006, 11:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •