GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Sony Xplod CD player install

    What factory wire goes to what aftermarket cd player wire when installing a (I don't know the exact model) Sony Xplod cd player into a 96 Silverado Z71 extended cab 5.7L vortec?

    I have the cd player working, but everytime I turn off the truck, turn it back on, it resets and its like it's not retaining any memory and settings. Also, the front speakers/tweeters don't work but the rear ones do. I have a "factory wiring diagram" from some pdf file website I had to pay $6 for to download. I also have the cd player wiring booklet. I don't have any of that in front of me at the moment, but was hoping somebody would know from doing it themselves with the same type of cd player I have.

    I know I don't have the green/white wire hooked up from the factory wiring. I couldn't figure out where it would go. Does it tie in to the constant 12V wire? If anyone needs any more information, I can have it later on when I go home. Thanks for any and all responses.
    1970 Chevrolet Chevelle SS 505ci/8.2L V8
    1996 Chevrolet Silverado Z71 350ci/5.7L V8

  2. #2

    Default

    Just happens that i just switched my Xplod out for a PYLE yesterday so the wires are fresh in my mind.

    Yellow = Power (all time)
    Red = Power (key)

    And the green/white wire sounds like a speaker negative. The wire with stripes are usually speaker grounds and the corresponding solid color wires and speaker positives.

    You didn't slice and dice the old stereo plug out did you?

    The reason why I switched the player out because every time you shut down the truck it beeps three times.

    Also get a light style wire tester. Takes a lot of guesswork out and is fun to use!
    Last edited by EagleTalons; 11-23-2008 at 07:02 PM. Reason: Info
    '93 Chevrolet Silverado 6.5L Turbo-diesel (Currently most reliable)
    '05 Honda Rancher 329CC (Flipped multiple times by different people)
    '72 Volkswagen Beetle 1.6L (Being rebuilt to 1641cc)
    '76 Chevrolet Scottsdale C20 350CI (My experiment!)

  3. #3

    Default

    It says in the print out I got that the green/white wire is for something else. I was wondering if somebody could put a wire by wire diagram.

    For example:

    Factory Sony Xplod
    Black Black
    Orange Red
    Yellow Yellow
    White Gray
    Gray Tan
    Last edited by 96Z71VORTEC; 11-23-2008 at 07:19 PM. Reason: messed up
    1970 Chevrolet Chevelle SS 505ci/8.2L V8
    1996 Chevrolet Silverado Z71 350ci/5.7L V8

  4. #4

    Default

    Did you cut the plug that hooks into the harness off? Also what does that green/white wire do?

    Also get out your wire tester and test these wires just don't hook blindly into them. Well you do have two sheets to reference on but, test them for good measure.
    '93 Chevrolet Silverado 6.5L Turbo-diesel (Currently most reliable)
    '05 Honda Rancher 329CC (Flipped multiple times by different people)
    '72 Volkswagen Beetle 1.6L (Being rebuilt to 1641cc)
    '76 Chevrolet Scottsdale C20 350CI (My experiment!)

  5. #5

    Default

    I completely removed the factory plug-in, and started with what I knew would go where from the diagrams. I have it hooked up to where it works when running/on/acc, and sound comes out. I just want it to retain the memory and hear sound out of the front speakers
    1970 Chevrolet Chevelle SS 505ci/8.2L V8
    1996 Chevrolet Silverado Z71 350ci/5.7L V8

  6. #6

    Default

    Ok, does the green/white wire come from the stereo or the vehicle? Also it sounds like you hooked into two key spots. Did you have a Delco 3 piece stereo stock?

    Did you buy a finishing kit too? Which replaces the center unit of the console so it looks like the stereo was meant to be there.
    Last edited by EagleTalons; 11-23-2008 at 07:42 PM.
    '93 Chevrolet Silverado 6.5L Turbo-diesel (Currently most reliable)
    '05 Honda Rancher 329CC (Flipped multiple times by different people)
    '72 Volkswagen Beetle 1.6L (Being rebuilt to 1641cc)
    '76 Chevrolet Scottsdale C20 350CI (My experiment!)

  7. #7

    Default

    The green/white wire is from the truck. I don't know about the Delco. I did buy the "finishing kit" and it fits in there good, however the back of the radio isn't supported much, although it isn't a big deal.
    1970 Chevrolet Chevelle SS 505ci/8.2L V8
    1996 Chevrolet Silverado Z71 350ci/5.7L V8

  8. #8

    Default

    Here's a cheap method I thought of. Take the front two speaker covers off and take them out. There are only about 4 screws holding each in. You can see which color the wires are. Also you can clean them. Mine...were disgusting. This may solve your speaker problem.

    As for the battery problem I will have to go look at my wires to confirm. I'll do that tomorrow.
    '93 Chevrolet Silverado 6.5L Turbo-diesel (Currently most reliable)
    '05 Honda Rancher 329CC (Flipped multiple times by different people)
    '72 Volkswagen Beetle 1.6L (Being rebuilt to 1641cc)
    '76 Chevrolet Scottsdale C20 350CI (My experiment!)

Similar Threads

  1. How to install an ipod adapter with factory cd player
    By chevyrulz in forum How-to Guides
    Replies: 10
    Last Post: 04-25-2011, 09:33 PM
  2. Xplod Woofer Box
    By Stealth in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 02-10-2010, 10:47 AM
  3. Sony X-Plode Speakers?
    By TRPLXL2 in forum Audio, Video & Gadget Tech
    Replies: 15
    Last Post: 12-05-2009, 11:09 PM
  4. Sony GT930 is Worth it?
    By iPublicEnemy47 in forum Audio, Video & Gadget Tech
    Replies: 11
    Last Post: 06-19-2009, 05:33 AM
  5. Replies: 0
    Last Post: 10-02-2007, 11:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •