GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default air/heat blower not working?

    2006 GMC Sierra Crew Cab 4.8
    The other night I got in my truck and turned the heat on, I could hear it click under the hood but nothing is blowing out. It started working two days later for about 15 minutes but then stopped again. I've checked all the fuses and they are fine. I don't have the $95 for the stealership to look at it. Any advice?
    Thanks,
    Cory
    _____ 1991 Ford Bronco Silver Anniversary ___
    __________________ ____________________



  2. #2
    Sr. Mechanic raisor87's Avatar
    Join Date
    Jul 2008
    Location
    the nasti nati
    Posts
    190
    Blog Entries
    2

    Default

    could be a relay, ohm out your old one possibly take out blower motor and battery test it just hold the leads to your battery and see if it runs if not bad motor. good luck
    1998 GMC Sierra SLE- Bone stock engine, 4'' in dash dvd 2 10" subs 800watt amp.

    1999 Buick Park avesdf

    1971 Buick Electra 225 built 455 and turbo 400

  3. #3
    Jr. Engineer bassalive's Avatar
    Join Date
    Nov 2008
    Location
    Marne, New Brunswick Canada
    Posts
    234

    Default

    This once happened to my wifes car. I removed the protective cover fom the fan removed it. It was packed full of straw etc. and I figured a mouse got in there somehow. I cleaned it and spun the blades untile the moved freely. Turned on the switch and bingo. It doesn't take a whole lot to jam one up.
    :sign0011:
    Troy
    New Brunswick, Canada

  4. #4

    Default

    It's possible it's just a loose connection somewhere. But Mice and rats are common problems with under hood issues. Just hope there isn't one in there when you remove the cover lol. Good luck.
    Mike - OREGON

    2001 chevy silverado 4x4. 5.3L, 6 inch Fabtech lift, 35" Toyo MT's, 17" Weld Racing wheels, arma coating on rocker panels. No exhaust after cat. Pioneer stereo

  5. #5

    Default

    Thanks for the help, I'm going to try some of those things out today.
    _____ 1991 Ford Bronco Silver Anniversary ___
    __________________ ____________________



  6. #6

    Default

    I took the motor out and tested it, it works fine. I noticed that on the plug, the one before the plug that goes into the motor, the ground is black and possibly melted a little bit. So, does that mean a short somewhere?
    _____ 1991 Ford Bronco Silver Anniversary ___
    __________________ ____________________



  7. #7

    Default

    That's what is sounds like to me but i'm no mechanic
    Mike - OREGON

    2001 chevy silverado 4x4. 5.3L, 6 inch Fabtech lift, 35" Toyo MT's, 17" Weld Racing wheels, arma coating on rocker panels. No exhaust after cat. Pioneer stereo

  8. #8
    Master Mechanic
    Join Date
    Oct 2008
    Location
    Brandon, FLA
    Posts
    747
    Blog Entries
    1

    Default

    Quote Originally Posted by gabronco91 View Post
    I took the motor out and tested it, it works fine. I noticed that on the plug, the one before the plug that goes into the motor, the ground is black and possibly melted a little bit. So, does that mean a short somewhere?
    Possible short right by the motor, trace the wires back from the motor and see if any are opened.
    Could have rubbed right in that spot, do you see any signs of it by the motor? Check any of the wires also in the area, by the relay located by the notor, should have 3/4/5 wires in a plug to the relay.


    Jeff
    JMoney02

Similar Threads

  1. Rear air and heat not working?
    By csmac2004 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 5
    Last Post: 10-17-2010, 11:23 AM
  2. Blower motor not working
    By lancer in forum General Chevy & GM Tech Questions
    Replies: 8
    Last Post: 06-28-2010, 05:18 PM
  3. my blower for heat wont work
    By 1995z71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 09-13-2009, 05:01 PM
  4. Front heat/ac blower fan question
    By sirfoulsalot in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last Post: 11-08-2007, 09:21 AM
  5. A/C Heat Blower Noise
    By THECHIN29 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last Post: 12-14-2005, 01:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •