GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 15

Hybrid View

  1. #1

    Default Warm start black smoke

    I've lingered here for a while, but this is my first post. Hopefully someone will have some ideas.

    I have a '99 C2500 Burb with around 80k miles on the 7.4L. A couple of weeks ago I noticed that on warm starts it will crank and crank before it starts up. Sometimes I'll have to pump the gas pedal a couple times. When it finally does start, there is a bit of black smoke that dissipates quickly. On cold starts, it turns over like a champ. No problems what so ever.

    Any suggestions?

    Thanks in advance!

  2. #2
    Moderator

    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Welcome to the site! hopefully another member here with knowledge on the 7.4 will jump in and shed some light on your problem.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  3. #3

    Default

    black smoke from a gasser??!!!??

    and by warm start you mean if you were to turn the truck off to order at a drive thru or sometihing?

    Ryan

    2002 Jeep Wrangler Sport 4x4 (the Yellow Jacket)
    4inch suspension 3inch body
    Straight 6 (383 Stroker within a year)
    36inch SuperSwamper TSL.
    105,000
    Detroit Loccers
    Daily Driver Weekend Wheeler
    much more...

    2004 Sierra crew cab, 2wd, 5.3 V8
    2inch Daystar Leveling kit
    single dumped Flowmaster 40 sieries exaust(removed)
    Mb Blitz Chrome wheels
    Leer Bed Cover(for sale)
    50k miles
    :glasses:




  4. #4

    Default

    Well, not exactly. It's more pronounced when after the truck has been driven enough to warm up, and then turned off for more than just a couple minutes, even up to a few hours.

  5. #5

    Default

    Quote Originally Posted by RussCrypto View Post
    Well, not exactly. It's more pronounced when after the truck has been driven enough to warm up, and then turned off for more than just a couple minutes, even up to a few hours.
    when was the last time the fuel filter was replaced?

  6. #6

    Default

    Just over a year and 15k miles ago.
    Last edited by RussCrypto; 12-07-2008 at 08:59 PM.

  7. #7

    Default

    One thing you might want to check is your coolant temperature sensor.

    the coolant temp sensor signal acts as a choke on fuel injected engines, when it is cold it puts more gas in the engine (like pulling the choke on your lawnmore when you first start it) and as your coolant temp warms up, it tells the computer to lean out the gas mixture.

    If the sensor is bad and is sending a cold coolant temp to computer, the computer would always be putting too much gas in. When you're starting from cold, that wouldn't be a problem, but when your engine is already warm, the air/fuel mixture would be too rich to start well and you'd need to open the throttle (pump the gas) to get more air in to allow it to start..the extra gas would come out as incomplete combustion and carbon deposits (black smoke)

    New sensor is only $11.99 and can be checked with a ohmeter

    Only thing is usually a bad CTS would cause a CEL code...but maybe it isn't bad enough to throw a code.
    Last edited by Big6ft6; 12-12-2008 at 05:02 PM.

Similar Threads

  1. black smoke
    By dshewy14 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 08-02-2010, 09:38 AM
  2. HOW TO smoke your lights
    By mill8365 in forum Chevy Truck Accessories
    Replies: 17
    Last: 03-10-2010, 09:53 PM
  3. 03' 6.6 wont start when motor is warm
    By hondahauler in forum GM Diesel & DuraMax
    Replies: 1
    Last: 08-20-2009, 10:05 AM
  4. Replies: 7
    Last: 01-16-2009, 01:04 PM
  5. I got smoke where there shouldn't be any
    By chicksuv93 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last: 05-28-2007, 09:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •