GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Limp mode activated with low beams

    2003 Chevy Suburban 2500, 6L, 208,000km

    The moment the low beam lights come on, or the day time running lights, the car goes into limp mode with an error code of 1518.

    Replaced the battery with a new one and checked the voltage with a DMM, with engine running, and found it to be 14.28vdc.

    Anyone know what could be causing this engine failure?

  2. #2

    Default

    UPDATE: This is how the problem needed to be fixed;

    So I tackled the LHS ground point behind the engine block, using a 15mm hex key. Polished the wire eyelets with a file and reinstalled it. A few photos to enlighten the reader:
    [image]http://www.flickr.com/photos/13753819@N02/3 102935819/in/photostream/ [/image]

    [image]http://www.flickr.com/photos/13753819@N02/3 102936275/in/photostream/ [/image]

    [image]http://www.flickr.com/photos/13753819@N02/3 102935913/in/photostream/ [/image]


    The easiest ground points to clean were located beneath the driver's door, as shown in the next photo.
    [image]http://www.flickr.com/photos/13753819@N02/3 103765826/in/photostream/ [/image]

    The ground point G103, located on the top rear, RHS of the engine block, was left undisturbed. (I was burned out with servicing it on the driveway). Instead, I spliced in a new wire to the old one and routed it to a new ground point at the front of the engine.

    Seeing how vulnerable these grounds are to weathering, I plan to splice every accessible negative wire, of every wiring loom circuit, to a bus bar, that in turn will be attached to the negative lead of the battery.

    The Suburban is running once again

Similar Threads

  1. Traction Activated
    By stevengerard in forum GM Powertrain
    Replies: 9
    Last Post: 11-15-2010, 07:01 PM
  2. 4l60e limp mode
    By crossleysierra in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 02-22-2010, 03:15 PM
  3. 2006 silverado limp mode with HID's
    By spencer in forum Member Introductions
    Replies: 6
    Last Post: 04-04-2009, 01:27 AM
  4. no low beams
    By bessyblue in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 01-26-2009, 07:53 PM
  5. 2001 No Low Beams
    By jhaney68 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 01-11-2008, 05:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •