GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10

Hybrid View

  1. #1

    Question Cold starting issue!

    i have a 97 Sub that is a pain to start when cold but runs super, any ideas well appreciated!
    Happy 2 Wheeler!

  2. #2

    Default

    Cold air temp sensor could be out of range.

  3. #3

    Default

    Quote Originally Posted by retired View Post
    Cold air temp sensor could be out of range.
    Thanks for your reply! No all I need to do is figure out where it is located and change it out.

    Phil
    Happy 2 Wheeler!

  4. #4

    Default

    Cold air temp should set off the check engine light. Might also be the fuel pump relay. If it goes bad, the fuel pump wont come on until the oil pressure comes up, which result in a long "cranking" session. Can you hear the fuel pump run for a few seconds when you turn on the key?
    Gary

    99 K 1500 Suburban
    78 Silverado Big 10 w/factory 454
    00 S-10 Blazer
    1976 Trans Am
    1980 Honda CB900 Custom

  5. #5

    Default

    I hear the pump kick in witht he key it seems to pressurize pretty quick under 10 seconds, also it runs great just is cranky when its is cold 3o degrees or less. In 45-50 it only turns about 1/2 to 3/4 of a turn and it is running, very quick start.

    Phil
    Happy 2 Wheeler!

  6. #6

    Default

    Cap, rotor, plugs and wires.
    Scott

    ΜΟΛΩΝ ΛΑΒΕ

    '94 Chevy Suburban K1500
    3" exhaust w/ aero turbine non-baffled muffler
    CFM Technologies TB spacer
    CB w/ 44" whip antenna


Similar Threads

  1. 96 K1500 hard starting when engine cold
    By kcstrom in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 08-25-2009, 08:54 PM
  2. jimmy starting issue
    By ChevyPrincess in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 07-20-2009, 09:03 PM
  3. Help starting issue!
    By FireRed in forum Performance & Fuel
    Replies: 2
    Last Post: 04-06-2009, 10:22 AM
  4. Starting issue
    By ferco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 11-13-2008, 08:29 PM
  5. Starting issue Please help
    By trivers in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 10-27-2007, 03:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •