GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 1 of 1
  1. #1

    Default Temp Guage Not Working

    Just changed my thermostat on my 1995 Tahoe 5.7l. Now the temp guage doesn't work, but was before.

    There are 3 wires that are grounded to one of the studs on the thermostat covering. They had to be replaced because the nut was frozen to the stud. I put nice new eye connectors on, even tested them directly to the ground and the guage still won't work (but I do not know if these grounding points are related to the guage).

    So, how do I diagnose why my temp guage isn't working? All of the other guages are working properly.

    Thx.

    BF

    UPDATE: I realizzed that the heater is not getting hot. So I am starting to believe I have an air bubble in the system. What is the best way to bleed the bubble out?
    Last edited by BIGFOOT; 01-01-2009 at 08:00 AM. Reason: Added add'l question

Similar Threads

  1. wiring up a transmission temp guage
    By sexysilverado25 in forum GM Electrical Tech
    Replies: 4
    Last Post: 04-29-2010, 09:43 PM
  2. temp. guage fluxuating
    By tcook18 in forum GM Powertrain
    Replies: 2
    Last Post: 01-13-2010, 12:46 PM
  3. Tranny Temp Guage
    By CarpenterGuy in forum GM Powertrain
    Replies: 7
    Last Post: 11-19-2009, 10:00 PM
  4. coolant temp guage stuck
    By L0sts0ul in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 11
    Last Post: 08-03-2009, 12:19 AM
  5. temp guage.
    By thebandit110 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 12-19-2007, 04:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •