GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 90 3/4 ton injectors not firing

    Hi all, this is my first post so it will be a bit of an intro also. My name is Jason and I own a used and abused (by previous owner) 1990 Chevy Suburban 2500. It has the TBI 350, a little over 300K on the chassis but the motor has about 100K and is out of a 93, at least that is what the previous owner said. The motor is stock except for a Holley TBI and Accell cap and rotor. It has an issue starting though. Here is the routine:

    • motor cranks for 10-30 seconds
    • check engine light comes on as oil pressure drops and comes back up again
    • truck will start (rarely will require a little throttle once it starts to fire) and c/e will clear


    I had my wife Sarah start the truck while I watched the injectors. They didn't start firing until the o/p dropped and the c/e light came on. Now here is the list of parts I have replaced so far (including parts replaced in a very recent tune-up):

    • plugs
    • wires
    • cap/rotor
    • coil
    • ignition module
    • fuel pump relay (brought the start time down to about 10 sec instead of almost 1 min!)
    • fuel filter
    • O2 sensor
    • Cat/Magnaflow cat-back (should have got the Flowmaster )
    • PCV valve
    • coolant temp sensor
    • MAP sensor


    The fuel pump is also supposed to be new, the previous owner said he replaced it right before I bought it less than a year ago.

    I have also tried SeaFoam with some results: Oil pressure has come down slightly(now about 25 from at least 35) and changes more with RPM. She seems to idle smoother but that could also be from the plethora of parts that has been thrown at her.

    I haven't checked the fuel pressure yet but I'm not really thinking that's the problem. From what I understand: the Injectors are activated by the ECM which receives a signal from the Ignition Module in the distributor as the motor cranks. If the ECM doesn't receive that signal, Oil Pressure is used as a backup: once the pressure reaches 4psi, the ECM activates the injectors.

    So with a new Ignition Module, am I to assume my ECM may be bad? I have tried the jumper technique for retrieving codes with no luck: the C/E light never comes on. And when my buddy used his scan tool he wasn't able to connect. I would think those would be some strong signs.

    Well, sorry to ramble but I wanted to try to give every bit of info I could up front. Thanks in advance for any and all replies. Here is a pic of my 'burb not long after I got her:
    Attached Thumbnails Attached Thumbnails my burb.jpg  

  2. #2
    Moderator
    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Nice looking truck! Whem I was reading I was thinking the same thing about the oil pressure cut-out switch.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  3. #3

    Default

    one less part to replace, it must be working lol

  4. #4

    Default

    This sounds like a fuel pump cutout switch problem.

    Could it be the injectors are firing but just no fuel in the rail?

    Maybe when the oil pressure comes back up it is letting the fuel pump run.

    Does the fuel pump turn on when the key is placed in "RUN".? It should run a couple seconds and then turn off if no oil pressure. If it does this then ECM ios probably OK. If it doesn't the ECM is stioll probably OK but a wiring or relay problem.

    I would look carefully at fuel pressure _while_ its starting.

    I would check out fuel pump relay circuits, oil pressure switch, fuel filter, etc. Also hook up a test light to the injectors connectors, one at a time. Are they really not firing because they aren't getting power?? Or are they getting power but no fuel to spray out?? Important difference.

    I would guess a faulty ecm as a last guess.
    '87 C2500 Burb, 5.7L 567k miles, dino oil changed every 10~12k
    '97 K2500 Burb, 5.7L 148k miles, dino oil

  5. #5

    Default

    Also, previous owners _never_ own up the whole truth when selling a vehicle. Maybe you have a new pump, maybe not. I always go through a vehicle myself and replace things a little ahead of schedule anyway, because I hate having to get a tow in the the middle of nowhere...and where I live there's a lot of nowhere. So stuff like water pumps, fan clutches, starters, alternators, fuel pumps, belts, hose, etc will get replaced on a used but "new to me" vehicle unless I can tell for abso-freaken-lutely sure they are new-ish, and aren't the cheap substitute junk.

    The point is...Maybe you have a wonky fuel pump, or the previous owner didn't install a new Delphi pump. I have had those cheap store-brand Chinese "Lifetime Warranty" pumps go dead within a month or two... Always when there is 40 gallons of gas in the tank <Laughing> and 30 miles from town. Lotta good that lifetime warranty does then...
    '87 C2500 Burb, 5.7L 567k miles, dino oil changed every 10~12k
    '97 K2500 Burb, 5.7L 148k miles, dino oil

  6. #6

    Default

    this is the article i have been going by

    10/6/2008
    THEORY/OPERATION -1993 Chevrolet Pickup C1500
    Page 2 of 5
    When ignition switch is turned to ON position, ECM turns electric fuel pump on by energizing fuel pump relay(replaced). ECM keeps relay energized if engine is running or cranking (ECM is receiving reference pulses from ignition module(replaced)). If there are no reference pulses, ECM turns pump off within 2 seconds after key on(runs constantly with key on). See FUEL MODULE under FUEL DELIVERY. <<<I CAN'T FIND THIS!!!
    As a back-up system to fuel pump relay, the oil pressure switch also activates fuel pump. The oil pressure switch is normally open until oil pressure reaches approximately 4 psi (.28 kg/cm 2 ). If fuel pump relay fails, the oil pressure switch closes when oil pressure is obtained, and operates the fuel pump. An inoperative fuel pump relay (replaced) may result in extended cranking times due to the time required to build up oil pressure. Oil pressure switch may be combined into a single unit with an oil pressure gauge sending unit or sensor.
    ECM monitors fuel pump circuit between fuel pump relay/oil pressure switch and fuel pump, enabling ECM to determine if fuel pump is being energized by fuel pump relay or oil pressure switch. A failure in this monitored circuit results in the setting of a related trouble code in ECM memory (can't access computer using scan tool or paperclip trick).
    For additional information on fuel pump activation, see F -BASIC TESTING and I - SYS/COMP TESTS article in this sections (i would love to but they didn't post that part).
    So it seems to be doing what it should to be doing if the ECM does not receive the signal from the Ignition Module.

    Does anybody know where the "hot fuel module" ("fuel module" as listed in the above quote)that the Chiltons manual shows in the wiring diagram? I did find a tan/blk + tan/blk connector behind me heater controls in the dash but it looked like it had a jumper stuck in it (probably why the pump runs constant instead of 2 minutes?).

    The injectors don't fire until the OP drops and comes back up and the C/E light comes on: I had my wife start it while i watched/listened to the injectors (you can hear them even with the hood closed)

  7. #7

    Default

    just an update:

    ended up being ECM-B fuse was bad. all that and it was just a bad fuse. now my check engine light works like it should and the truck starts almost flawlessly.


Similar Threads

  1. Firing order Gen question
    By stuntworks in forum GM Powertrain
    Replies: 1
    Last Post: 02-04-2010, 07:33 PM
  2. firing issues?
    By silvy_1994 in forum GM Powertrain
    Replies: 4
    Last Post: 12-01-2009, 10:02 PM
  3. Even critics say firing GM CEO is a bad idea
    By Steve in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 12-09-2008, 06:22 AM
  4. 97 vortec engine firing sequence..?? help..!!
    By jc97sub15004x4 in forum GM Powertrain
    Replies: 2
    Last Post: 04-04-2008, 02:36 PM
  5. 89 suburban 5.7 350 firing order diagram
    By 89suburban350 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 11
    Last Post: 08-29-2007, 06:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •