GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 99 Silverado Cruise control problems

    So I just got my new truck today, and coming home from the dealer I went to use cruise control on it. It worked great and fine in the test drive, and when I got on the interstate coming home, the first part of coming home that is. so I stopped for lunch, then after that the cruise didn't work at all the rest of the way home, some 90 miles. So after that I had another trip to make for work, so I tested the cruise again.... worked fine, but I had 3 bridges under construction, and when I went to get the cruise back on after the last bridge, same story cruise didn't work. What could be my issue?

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    well its ten years old and they dont last forever is one of them, mine in my burban does the same, i just deal with it. Most likely you replace the blinker stalk and its taken care of, i have seen these on ebay pretty cheap. It can also be a sensor for the throttle, after years and years of setting the cruise at say 55 or 65 it can were out that area on the cable and cant read what it needs to, this is what i have been told anyway.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    Quote Originally Posted by vncj96 View Post
    well its ten years old and they dont last forever is one of them, mine in my burban does the same, i just deal with it. Most likely you replace the blinker stalk and its taken care of, i have seen these on ebay pretty cheap. It can also be a sensor for the throttle, after years and years of setting the cruise at say 55 or 65 it can were out that area on the cable and cant read what it needs to, this is what i have been told anyway.
    humm never heard of the sensor for the throttle issue...
    one thing I've been wondering, could it be the brake pedal switch?

  4. #4
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    if it was the brake issue, then your brake lights would be coming on and it would drain the battery at night. My guess is the blinker stalk or the cruise button itself
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  5. #5

    Default

    Quote Originally Posted by vncj96 View Post
    if it was the brake issue, then your brake lights would be coming on and it would drain the battery at night. My guess is the blinker stalk or the cruise button itself
    yeah dad is thinking that is the issue too. he thinks that it could be a loose connection or dirty contacts on the stalk....

Similar Threads

  1. 2005 Impala cruise control problems
    By bsharles in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 05-15-2010, 10:33 PM
  2. silverado 1500 cruise control problem
    By mitchlbuck in forum GM Powertrain
    Replies: 4
    Last Post: 02-28-2010, 11:19 PM
  3. 99 silverado 2500 cruise control parts
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 02-01-2010, 01:50 PM
  4. 2008 Silverado sloppy cruise control
    By n6vig in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 11-30-2009, 06:05 PM
  5. '08 silverado cruise control add- on
    By brianmerriam in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 12-13-2008, 07:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •