GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default instrument panel light problem

    i have a 89 k2500 chevy and when i turn on the headlights or the parking lights the instrument panel lights go out but the turn signal indicator lights stay on, the high beam indicator light goes on when the low beams are on and go out when the high beams are on, the warning lights work just fine.....once in a while they will come back on and then go right out a couple minutes later or when you go to start the truck back up......btw sometimes when i hit the bottom left side of the instrument cluster they go on.....i think it might be a short but i cannt find a place in the dash to check the wiring to the cluster.......if anyone has an idea of how to fix this or knows whats going on it would be appreciated......thanks

  2. #2

    Default

    How are the fuses?? Any blown ??
    Ryan

    2002 Jeep Wrangler Sport 4x4 (the Yellow Jacket)
    4inch suspension 3inch body
    Straight 6 (383 Stroker within a year)
    36inch SuperSwamper TSL.
    105,000
    Detroit Loccers
    Daily Driver Weekend Wheeler
    much more...

    2004 Sierra crew cab, 2wd, 5.3 V8
    2inch Daystar Leveling kit
    single dumped Flowmaster 40 sieries exaust(removed)
    Mb Blitz Chrome wheels
    Leer Bed Cover(for sale)
    50k miles
    :glasses:




  3. #3
    Jr. Mechanic
    Join Date
    Dec 2008
    Location
    Gettysburg, Pa.
    Posts
    103

    Default instrument panel

    Do you have a little aluminum block in your fuse panel? If so these are cube relays, one of them may be bad, see if tapping on it with a screwdriver handle makes the lights come on.

  4. #4

    Default

    no none of the fuses are blown and no there is not a relay fiy either the cluster or headlights

  5. #5
    Jr. Mechanic
    Join Date
    Dec 2008
    Location
    Gettysburg, Pa.
    Posts
    103

    Default inst. panel lights

    The relay will be designated as "accessory"

  6. #6
    Jr. Mechanic SilveradoBrett's Avatar
    Join Date
    Oct 2008
    Location
    Fort Lupton, CO
    Posts
    99
    Blog Entries
    1

    Default

    This situation reminds me of my truck. My dash does all kinds of weird things like that. First of all the oil pressure guage bounces around constantly and never stays in one place for more than a few seconds. The truck draws too much power and when it does the radio just shuts off and turns on repeatedly so I only hear a few words of each song. The volt guage will drop all the way down to nine and then suddenly bounce back up to 13. Its really weird and I have not been able to figure it out! I have a 96 K1500 Silverado and I am so frustrated by it because the problem has left me stranded in the past but continues to persist. (Look at my Silverado Blues Post) I actually took it into the shop today to see if a "certified" electrical monkey could get it fixed. My thoughts are that the cluster motherboard is shot and needs to be replaced. I should know later today if they could figure it out and get it fixed. When I do I will post the solution on here and maybe it will help you out. Good luck!
    1996 Chevy K1500 Silverado Z71
    -248000 miles
    -The legendary 350 small block V8 (5.7L)
    -Sound System with a 10'' kicker L5 sub and 1300W amp in a sealed box



  7. #7

    Default

    i think that i found the problem.....the contact on the wiring harness was not connecting good that oes to the cluster lights....i just bent the metal holder in the contact for the pin and they came back on.......thanks for the help

  8. #8
    Jr. Mechanic SilveradoBrett's Avatar
    Join Date
    Oct 2008
    Location
    Fort Lupton, CO
    Posts
    99
    Blog Entries
    1

    Default

    Well that was a nice and easy fix! Good work! I finally got my truck working again and it was just missing grounds. Battery to body, body to frame, body to motor. That was what was causing all of my problems. Glad you figured it out!
    1996 Chevy K1500 Silverado Z71
    -248000 miles
    -The legendary 350 small block V8 (5.7L)
    -Sound System with a 10'' kicker L5 sub and 1300W amp in a sealed box



Similar Threads

  1. Instrument Panel Bulbs
    By Stonewall42 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 01-20-2010, 10:51 PM
  2. Brake light on instrument panel...
    By TUTONE in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 04-23-2009, 06:10 AM
  3. Instrument panel lights went out
    By johncc in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 10-01-2008, 08:56 AM
  4. Instrument panel brake light
    By chevyvega in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 08-14-2008, 09:17 PM
  5. 2001 2500HD Instrument Panel Problem
    By CWF in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 08-31-2007, 07:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •