GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 54
  1. #41

    Default

    I have an 02 Z71 EXT, had the same problems. My issue ended up being my shackles ( leaf springs ). They were old and rusted and were actually popping on takeoff when the truck would squat. Dealer said to lube them up with WD-40 every now and then, and it has worked, no more clunking.

  2. #42

    Default

    If it's a 4X4 and has the torsion bar front suspension, check the torsion bar cross member mounts. They mount the torsion bar cross member to the frame, and have rubber bushings. I replaced mine last year after hearing a clunking sound taking off from a dead stop. They're pretty easy to replace. All you have to do is cut the rivets with a high speed grinder & pop them out with a hammer & drift, then bolt in the new ones. Use grade 8 bolts with flat & lock washers and Ny-lock nuts. takes about 1 hour to do.
    Last edited by thrasher; 03-04-2010 at 07:37 PM. Reason: miss spell
    You're driving is WAY more offensive than my swearing, assjack!!!


  3. #43

    Default

    The noise is coming from the slip yolk, the only way to get rid of it, is to replace it with the nickle plated one that gm uses to fix the clunk problem. This is a super common, often miss diagnosed problem. I'm not sure it the part is available to the aftermarket, but you should be able to go to any gm dealer parts dept. and order one, they probably have it on the shelf.

  4. #44

    Default clunking noise is usually an indicator of something wrong

    First, check the vehicle for loose objects rolling around-anywhere in or out of the vehicle.
    Next, if the U-joints are OK you may want to change the rear-end oil.
    It probably has an Anerican axle "G-80" option for trailering which has clutches.
    Bring your VIN number to the dealer and get a factory gasket, DELCO synthetic rear-end oil and DELCO limited slip additive. Wipe as much of the old clutch material and smudge as you can and check for foreign debri. Fill the additive after the first jug of rear end lube to ensure the littel container of additive gets entirely put in. Fill with lube to it's oozing out of the fill plug.
    I worked in theGM St. Catharines Components plant and the guys in the lab told me this. It's now closed and outsourced to American axle.

  5. #45
    Sr. Apprentice 1500ExtChevy's Avatar
    Join Date
    Mar 2010
    Location
    Lemont, Illinois, United States
    Posts
    70

    Default

    I was gonna say I bought a 2005 Silverado Ext. Cab about 3 days ago now bought (3-6-10) and when braking doesnt do it but taking off you hear the clunk. But if you come to a stop and slowly take off theres no noise. I've noticed it but havent done much about it well it being 3 days old but I just watch myself as far as the take off by taking it slow which is quite the challenge.
    2005 Silverado 1500 5.3L 4x4
    285/70/17 Firestone Destination MT's
    17" Pro Comp Extreme Wheels
    2" ReadyLift Leveling Kit
    Blacked Out Grill and Front and Rear Bumpers (Painted By Me)
    PreRunner Light Bar (Removed) New Fabricated Bumper (coming soon)
    WeatherGuard Tool Box (Painted Also)

  6. #46
    Sr. Apprentice
    Join Date
    Nov 2009
    Location
    San Marcos
    Posts
    65

    Default

    I would suggest checking the carrier bearing.
    2001 2500HD 4x4 8.1L/ally,CCSB,diablo with diablew tuned and too much to list....

  7. #47

    Default

    my truck has the same problem. anyone have a definitive solution for this?
    So far the solutions I've seen for this problem are: replacing slip yoke, pcm codes, replacing transmission valve body, oiling leaf springs, changing rear end oil.
    Anyone know which one is the right fix? I'm guessing the slip yoke, but also the pcm causing low pressure in the transmission lines seems plausible
    2004 Z71 Tahoe
    2004 Silverado LT
    1995 Sierra SLE

  8. #48

    Default

    Quote Originally Posted by gig'em View Post
    my truck has the same problem. anyone have a definitive solution for this?
    So far the solutions I've seen for this problem are: replacing slip yoke, pcm codes, replacing transmission valve body, oiling leaf springs, changing rear end oil.
    Anyone know which one is the right fix? I'm guessing the slip yoke, but also the pcm causing low pressure in the transmission lines seems plausible

    why don't you simply pull the driveshaft and lube that yoke? it's about 15 minutes and $10 fix. if it fixes it - well, now you know what is causing the clunk. unless you just itching to go fancy and expensive on repairs.
    DON'T FIX IT IF IT AIN'T BROK. IF IT'S BROK - FIX RIGHT AWAY.
    WONNA THINGS DONE RIGHT, DO THEM YOURSELF

    2000 SILVERADO, CENTURION EDITION, 4WD, Z71, 5.3 VORTEC
    NO DUMM MODS

  9. #49
    Jr. Apprentice meandmyharley61's Avatar
    Join Date
    Sep 2011
    Location
    dansville, new york
    Posts
    29

    Default

    Hello everyone, I had this situation with my 2005 silverado LS 4WD. I had the splines greased according to what I read here on this forum. It soon came back; it was irritating, to say the least. But, I learned to live with it. I had bought this truck used in june of 2011. I love it! traded in a dakota for it. decided to start doing some mods to it. so far I have done; a diablo tuner with a diablew tune, catback dual exhaust, K&N drop in air filter. And a truxx front end leveling kit. I have noticed that my clunk disappeared! I dont know why; or If it is even related. but, it is gone and has been for a bout three months now. I installed the leveling kit in november.
    Bill Knapp

  10. #50

    Default

    Quote Originally Posted by meandmyharley61 View Post
    Hello everyone, I had this situation with my 2005 silverado LS 4WD. I had the splines greased according to what I read here on this forum. It soon came back; it was irritating, to say the least. But, I learned to live with it. I had bought this truck used in june of 2011. I love it! traded in a dakota for it. decided to start doing some mods to it. so far I have done; a diablo tuner with a diablew tune, catback dual exhaust, K&N drop in air filter. And a truxx front end leveling kit. I have noticed that my clunk disappeared! I dont know why; or If it is even related. but, it is gone and has been for a bout three months now. I installed the leveling kit in november.
    Bill Knapp
    Saying that the clunk went away without any kind of solution (to me) sounds like saying my rear end has a leak, not fixing it, and then later on noticing that the rear has quit leaking... you didnt solve the problem it got worse. I would actually like to find the solution to this problem.. as Z10002003 said they have the nickle plated part available, would like to know if that's an ACTUAL permanent solution and how well it has worked. I have the same issue in my truck and both NBS 'rados before it. When i took it to the dealer they simply greased where the splines connect on the driveshaft and transmission. Problem solved (to them). But the clunk still exists a week or two after the grease-job. It is very annoying and definitely (to me) will eventually cause further issues. I am going to talk to my buddy who works for a GM dealer as a tech and see if he has any insight on a PERMANENT solution any of their technicians have found.

    "If you're not living life on the edge, You're taking up too much space"

    "Truck Norris"
    - 2008 TX Edition Silverado
    - McGaughy's 4/5 Drop Kit
    - Apline Type R 10s & Amp
    - Pioneer 6 Disc Touchscreen Deck
    - Nightmare Breed Motorsports custom tune
    - Custom 3" dual exhaust through x-pipe dumped at axle
    - Airaid CAI
    - Badges and molding removed, roll pan, Truxedo roll-up cover (compliments of GMTC!), 3pc billet grille, factory fogs upgrade
    "Kristine" - 1991 Nissan 240sx
    - Cut to pieces, LS build pending

Page 5 of 6 FirstFirst ... 3456 LastLast

Similar Threads

  1. 2004 Silverado has a clunking noise from the front end
    By Banshee in forum GM Powertrain
    Replies: 3
    Last Post: 02-20-2010, 12:26 PM
  2. Clunking noise
    By Minnesota Mudder in forum Lifted & Offroad Suspension
    Replies: 3
    Last Post: 01-13-2010, 11:35 AM
  3. Clunking Noise in Rear End
    By dizzy17 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 12-10-2009, 09:43 PM
  4. Clunking noise
    By helomech09 in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 07-31-2009, 07:46 AM
  5. Clunking noise issue
    By gasixgunner in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 04-13-2009, 07:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •