GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Audio troubles and electrical issue

    I have a 1997 Chevy Blazer (4 door). My radio works, and the speakers in the front of the car work just fine; but my c.d. player will not play any c.d's and my rear speakers make no sound. I also have trouble with my back window wiper, it works once every 6 months for about 1 minute. Very frustrating given that I live in Washington. Any clue if my problem is a power shortage to the rear or if it's the speakers? It'd be a pain to take the door apart and check the speaker so I'm hoping there's an easier way. Thanks!
    Last edited by Springthing; 02-03-2009 at 07:46 AM.

  2. #2
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Is this factory radio? If so... it could be that your CD player has just given up with it being 11 years old.

    What happens when you put a CD in?
    When is the last time you cleaned it?

    I wouldn't bet on getting the CD working again but might want to try getting a bottle of duster air stuff (available at walmart in the computer department..) and blow the heck out of the inside of that thing. Might help but doubt it!

    As for the rear speakers, we need to find where the problem is. Do you have a spare speaker by chance? Are you able to get to a salvage yard to buy one that is guaranteed not blown? Should be less than 5$, really. But you can take the speaker and hook it up to the rear leads and see if it works. If it does, then your rear speakers are dead.

    What I'd suggest doing.. even though it's a little more involved.. is pulling out the radio, and moving the wires from the front and rear speakers and invert them so that the front wires coming out of the radio power the rear speakers. If you get sound form the rear then the radio might be at fault. If you STILL get nothing then you've narrowed the problem down to the wiring or rear speakers themselves. Hooking up the rear speakers to one that you know works as suggested above will tell you for sure where your problem lies.

    Good luck.
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




Similar Threads

  1. electrical issue ?
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 0
    Last: 06-15-2010, 10:25 PM
  2. Trans electrical(?) issue
    By bigdogdaddy in forum GM Powertrain
    Replies: 1
    Last: 05-28-2010, 03:20 PM
  3. Electrical Power issue
    By ColonialRovers in forum General Chevy & GM Tech Questions
    Replies: 16
    Last: 10-06-2009, 09:20 PM
  4. electrical issue??
    By GReddy212 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 04-04-2009, 08:50 AM
  5. 10" dvd monitor - audio issue
    By sstoner911 in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 09-18-2008, 11:46 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •