GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Fan switch problem

    The heater/ac fan switch on my 03 Sierra seems to bad or is it the blower motor? It seems to only work on high speed setting #5. Any info or help please. Thanks, Tom

  2. #2
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Had the same issue with my Suburban. It ended up being the control module itself (the switch box).

    Here is the recap story:

    http://www.gmtruckclub.com/forum/showthread.php?t=14647
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  3. #3
    Moderator

    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Blower motor resistor needs replacing.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  4. #4

    Default blower

    Thanks for the help fellow Washington resident. I'm from Spokane and appreciate the help if I can find where it goes. The dealer should know with a pic when I get the parts. Thanks !! Tom

  5. #5

    Default

    You talking about the thing on the dash to change temp and fan speed?
    2000 Chevy Silverado 1500 5.3L Z71 - 4x4


  6. #6

    Default switch

    Yes, it appears to be in the swich knob on the dash but have been told the blower just needs the resitor replaced. I'll get one today and try that. Sound correct as I only get high speed #5 out of the fan so it does work just not on the lower speeds. Thanks for the help all.

  7. #7

    Default

    Quote Originally Posted by Bluewater View Post
    Yes, it appears to be in the swich knob on the dash but have been told the blower just needs the resitor replaced. I'll get one today and try that. Sound correct as I only get high speed #5 out of the fan so it does work just not on the lower speeds. Thanks for the help all.
    idk if you already got the switch, but they do go on ebay around 100 bucks, maybe cheaper. i just remember the other day i saw one buy it now for 85. dont know what the dealer charges...but post how much it set you back after you get it.

  8. #8

    Default

    Hi, I am new to this so I'm not really sure what I'm doing...
    We have replaced the fan speed switch twice, the first time we replaced it; the switch was melted, we put another switch in last year and the switch worked, but the other day the heater stopped working agian, so we took out the switch agian, this time not only is the switch melted but the pigtail that's connected to the wires is melted too?? The fuse is fine, but now I don't know what to do?? Can someone please help me!?

Similar Threads

  1. Suburban Ignition Switch/Instrument Cluster Problem?
    By JAL1959 in forum GM Electrical Tech
    Replies: 10
    Last: 10-27-2012, 12:04 PM
  2. 96 Chevy tahoe problem fuel problem? Need help ASAP!
    By Fear58 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 12-13-2009, 05:38 PM
  3. 99 Tahoe Dome light door switch problem
    By Badbrad10 in forum GM Electrical Tech
    Replies: 1
    Last: 12-12-2009, 08:57 AM
  4. Colorado blower switch problem
    By rider89 in forum Audio, Video & Gadget Tech
    Replies: 8
    Last: 06-03-2009, 07:35 PM
  5. Drivers window from Master Switch Problem
    By uscs04 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 07-24-2008, 05:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •