GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1

    Default '03 Silverado, cigarette lighter stopped working

    I have already done a search on every key word I can think of for this, but can't find what I'm looking for. I'm a moderator on another forum so I know how annoying it is for someone to ask a question that has been asked a thousand times.

    But anyway, the cigarette lighter stopped working. I have a Garmin GPS that I use a lot, and I've also got phone chargers, and a thing to play my iPod through the radio that I need to get power to sometimes, so I need both the accessory outlet and the cigarette lighter to work. I have checked the fuse on the drivers side of the dash, as well as the one under the hood. Or at least the fuses that I thought were the right ones. Is there anything else I need to check? Could the cigarette lighter itself be bad? I even pulled the center piece out of the console to make sure they wires hadn't come loose, and they are still connected.

    Thanks for any help!!

  2. #2

    Default

    Hmm...you checked everything I would have suggested. The only other thing I can think of is the plug itself has gone bad. Maybe someone else will have some other suggestions.
    Matt
    Hallsville, TX

    2005 Silverado 1500 LS Crew Cab 5.3L 2WD
    K&N FIPK II
    Magnaflow Exhaust
    Hypertech Max Energy Programmer
    Suspension Leveling Kit
    Putco Element Window Visors
    Carriage Works Billet Grille
    TruXedo TruXport Tonneau Cover


  3. #3

    Default

    I thought I had found it today on my lunch break. I was double checking all the fuses, and the 2 green 20 amp ones were good, but then I saw a blue 15 amp fuse that was for the lighter that I'd never seen before. So I pulled it and it was shot. I thought "Well good, that's the problem." So I put a new fuse in and the lighter still doesn't work, so I'm right back to where I was.

  4. #4
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Re-check that fuse if you haven't already! Might be blown again, suggesting a short somewhere along down the line!

    I'd get to work with a voltmeter. Check fuses (may as well check all the fuses while you're there.. takes about 5 minutes to check them all with the little plastic fuse puller they give you. Same for under the hood. Once you've sure everything is ok with the fuses, I'd grab the voltmeter and check the wiring behind the panel you had off that power the cigarette lighters. Most voltmeters have sharp leads for a reason... reason is for situations like this. Just (CAREFULLY) poke the leads through the insulation and test the wires with the truck in at least the acc. position.

    That's about all I can suggest. If you've got no power at the wires.. then it would be a matter of either checking the wiring all along the route, if you can follow it (most likely will NOT be able to).

    *IF* you have no power and can't figure out what the heck is going on, I would, personally, just save myself the hassle and run a fresh power wire to the outlets. Can even put in a small rocker switch on your dash somewhere if you'd like so you can flip the outlets on/off. (switch and then through a relay, please!)

    Hope that helps a little!
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  5. #5

    Default

    Well, I feel like an idiot. :slap:

    We got to checking with a test light, and found the problem. We checked all the fuses, and all of them were good. Checked the plug itself, and it still wouldn't work. So I pulled the center piece out of the console and the wire was just dangling. My brother said "You dumb ass, there's what's wrong with it." I told him that I was SURE it wasn't dangling the other day when I looked. So he stuck the test light to the end of the plug, and it lit up. So we plugged the wires back up to the lighter, and it works again.

    I felt so dumb and embarassed. But I KNOW that the wires were connected the other day when I first looked. I guess the plug connector was loose and wasn't making contact or something. But anyway, I just wanted to let ya'll know what the problem was and say thanks for the help. So thanks again, I really appreciate it!

  6. #6
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Another problem solved! Good detective work!
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  7. #7
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    you might try checking the fuse block under the hood also , typically up near the firewall on the drivers side

  8. #8

    Default

    Quote Originally Posted by gtilley45 View Post
    Well, I feel like an idiot. :slap:

    We got to checking with a test light, and found the problem. We checked all the fuses, and all of them were good. Checked the plug itself, and it still wouldn't work. So I pulled the center piece out of the console and the wire was just dangling. My brother said "You dumb ass, there's what's wrong with it." I told him that I was SURE it wasn't dangling the other day when I looked. So he stuck the test light to the end of the plug, and it lit up. So we plugged the wires back up to the lighter, and it works again.

    I felt so dumb and embarassed. But I KNOW that the wires were connected the other day when I first looked. I guess the plug connector was loose and wasn't making contact or something. But anyway, I just wanted to let ya'll know what the problem was and say thanks for the help. So thanks again, I really appreciate it!
    lol, happens to the best of us! Glad you found the problem!
    Matt
    Hallsville, TX

    2005 Silverado 1500 LS Crew Cab 5.3L 2WD
    K&N FIPK II
    Magnaflow Exhaust
    Hypertech Max Energy Programmer
    Suspension Leveling Kit
    Putco Element Window Visors
    Carriage Works Billet Grille
    TruXedo TruXport Tonneau Cover


  9. #9
    Sr. Apprentice Tater's Avatar
    Join Date
    Feb 2009
    Location
    Florida some of the time
    Posts
    37

    Default

    Well that was something i never thought to try so dont feel bad... I also have an '03 silverado with the cig lighter not working. did the fuse check also and they just said screw it, i dont smoke anyhow, and really just use it to charge my spot light during hunting season. now i reckon i should check what you found hu?? thanks for doin the leg work for me!

  10. #10
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    Quote Originally Posted by gtilley45 View Post
    Well, I feel like an idiot. :slap:

    We got to checking with a test light, and found the problem. We checked all the fuses, and all of them were good. Checked the plug itself, and it still wouldn't work. So I pulled the center piece out of the console and the wire was just dangling. My brother said "You dumb ass, there's what's wrong with it." I told him that I was SURE it wasn't dangling the other day when I looked. So he stuck the test light to the end of the plug, and it lit up. So we plugged the wires back up to the lighter, and it works again.

    I felt so dumb and embarassed. But I KNOW that the wires were connected the other day when I first looked. I guess the plug connector was loose and wasn't making contact or something. But anyway, I just wanted to let ya'll know what the problem was and say thanks for the help. So thanks again, I really appreciate it!
    there used to be a time that GM actually installed those things in a manner that they didn't just randomly come lose like that. in fact I've had some vehicles that you almost had to break the plug to get it off of the back of the lighter assembly. guess that's not so much of an issue any more. now you gotta hot glue them on or something from the sounds of it.

Similar Threads

  1. Power locks and cigarette lighter fuse
    By kguygm in forum GM Electrical Tech
    Replies: 4
    Last Post: 04-07-2014, 05:30 PM
  2. 04 silverado temp/compass stopped working
    By drumm14 in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 05-26-2009, 05:24 PM
  3. 88' Z71 4wd stopped working
    By Jagerballs in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 03-05-2009, 02:02 PM
  4. Cigarette Lighter help
    By BigRedHusker in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 02-22-2008, 07:10 AM
  5. 2005 Z71 Cigarette Lighter "Blow Out"
    By corburns in forum Audio, Video & Gadget Tech
    Replies: 3
    Last Post: 02-20-2008, 06:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •