GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Thread: It just died

  1. #1

    Default It just died

    Hey Guys&gals, newbee her and I have a Question for you guys, I was going down the interstate about 70mph yesterday, and my 2006 s1500, with a 4.3V6 just died. I tried to restart, and the motor would just spin but not fire. I checked the sparkplugs and no fire at all. I have voltage at the ICM and at the Coil. I replaced both the coil and the ignition control module, still nothing (no spark). Also no codes are showing up on scanner. Truck has 50,000 miles on it. and of course its out of warranty.
    Any suggestions would be greatly appreciated.

  2. #2

    Default

    I see that you have no spark, but is that from the coil or to the wires?


    Chris
    2005 Silverado - 4.3L, 5spd Manual, K&N Drop in Filter, Modded Air box
    Kenwood KDC-MP732 Head Unit, Pioneer 760W Amp, 2x 10" MTX Thunder 6000 subs, Uniden PC68XL CB/PA

    2004 Cavalier - 2.2L Auto
    Bone Stock

    1977 Toyota Celica GT - 20R (2.2L), 5spd, 146,000 Miles all Original (even the clutch)

  3. #3

    Default

    You might want to perform a compression test, or just pull a plug and put your finger on the spark plug hole and see if it blows back. Does the truck crank over a lot faster now, after the stall and die. Could be the timing chain failed. If not,you really need a scanner that will show live data, to see if you have reference RPM going to the computer. Without reference signal, you would have a ignition problem. You can buy a scanner that shows live data, at autozone for about $150.00. Get back and tell us what the problem was once it's fixed. Good Luck.

  4. #4

    Default it just died

    I have spark coming out of the coil, but not at the sparkplugs. I put a new accel hp distributor cap and rotor on today and still nothing. Scanner shows no codes.

  5. #5

    Default

    Before you get ahead of yourself try to rule out what the problem is. You need compression fuel/air and spark for ignition. Make sure you have all of those first. Could be as simple as a fuel pump/filter.

  6. #6

  7. #7
    Jr. Mechanic TMRuiz's Avatar
    Join Date
    Dec 2008
    Location
    Gonzales, Louisiana
    Posts
    147

    Default

    If you have spark coming from the coil but not from the plug wires you might have a busted dist. pull the cap and spin it it over to see if the rotor is spinning. If you changed the rotor cap plugs and wires but still have no spark from the wires it's a good chance that rotor isn't spinning to transfer spark to the plugs.

  8. #8

    Default

    Found the problem, it was the pin connector (12volt) that plugs into the coil. When I checked it for voltage, it had 12volts, but when it was plugged in it was sending less than 12volts to coil, so I was getting spark to the distributor but it was weak. Never had a connector on a vehicle in 38 years of owning cars and trucks ever do that before. So much for buy American.

Similar Threads

  1. Died on me
    By Allmostsmart in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 04-07-2010, 11:26 PM
  2. My tranny died...UGH
    By trapper_canada in forum GM Powertrain
    Replies: 2
    Last: 02-19-2010, 06:04 PM
  3. Died while driving?
    By kingkevin8 in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 12-06-2009, 11:03 AM
  4. Truck Died
    By al96chev in forum General Chevy & GM Tech Questions
    Replies: 12
    Last: 11-18-2009, 11:31 PM
  5. Ted Rogers has died at the age of 75
    By Cableguy in forum The Coffee Shop ~ Chit Chat
    Replies: 3
    Last: 12-02-2008, 02:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •