GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 1 of 1
  1. #1

    Default 2003 Silverado Speed Sensor? (thought it was a cluster problem, maybe not?)

    vehicle is a 2003 silverado 4x4 Z71, 5.3L V8, approx 103k miles.

    I had the famous problem of a sticking speedometer needle in the gauge cluster when it got cold outside. This weekend, I replaced all 6 stepper motors in the gauge cluster. It was a pain in the ass, but I got it done.

    My gauges seem to be working okay now, but the response of my speedometer needle seems to be delayed. For example, when I slow down, it seems like it takes longer than it should to return to zero. For instance, if I drive 20-mph, then stop at a stop sign, it will still be traveling back to zero for a few seconds after I stop.

    This leads me to believe it wasn't the stepper/stepping motors in the cluster - and maybe it's something else. Is it possible that there is some kind of speed sensor that has started to malfunction?

    I always wondered why my speedometer would always stick when it got cold (and no other gauges).

    Any advice? How many speed sensors are there, where are they, and can I replace them?

    Thanks for the help!
    Last edited by 2003_Z71; 01-23-2012 at 08:39 AM. Reason: typo

Similar Threads

  1. Replies: 0
    Last: 11-28-2011, 11:50 PM
  2. Replies: 0
    Last: 11-23-2011, 01:00 AM
  3. Replies: 0
    Last: 10-26-2011, 01:40 AM
  4. NNBS silverado wheel speed sensor problem
    By deepstuff in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 09-24-2011, 09:05 PM
  5. Vehicle Speed Sensor 04 Silverado 1500
    By elGordo0524 in forum GM Powertrain
    Replies: 0
    Last: 11-09-2009, 10:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •