GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Sevice 4WD???? [Expired Topic]

    I just recently bought a 2003 Avalanche, and I was wanting to know if there might be some kind of recall on the 4WD system in it. You see, my "Service 4WD" indicator turns on once in a while, and I can't figure out the problem. My 4WD still worls, and it works fine, believe me, I've already tried it out, but I was wondering if the light comes on because I need to work on my transmission, or if it could be a malfunctioning sensor. If someone out there is encountering the same problem, and can help me, please do. I'd gladly appreciate it.

  2. #2

    Default RE: Sevice 4WD????

    I have been battling "service 4wd" indicator for past 6 months now on 2005 Chevy Suburban LT. First time, dealer said no code stored in sensor - did not get charged since no work was actually done. 2nd time - they found "no ground" on motor which engages 4wd. They supposedly cleaned all ground contacts and got the sensor clear (got charged $152 for labor). 3rd time - after complaining to my service manager - they tested it extensively and found the motor which engages the 4wd to be defective. Even though my car had 51k miles on it (outside of warranty), they replaced motor for free.

  3. #3
    Sr. Apprentice rmreid's Avatar
    Join Date
    Mar 2006
    Location
    South Western, TN
    Posts
    44

    Default

    Had the same issue on my '03 Z71 and never a fix. I do remember that they changed the dash switch, reprogrammed software and when that didn't work I finally gave up and traded it in.
    Bob
    Millington, TN
    2006 Chevy Silverado Z71: Silver Birch Metallic(59U)/Gray Leather


  4. #4
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Any news on this Jose?
    Patrick
    Rhode Island


  5. #5
    Sr. Apprentice rmreid's Avatar
    Join Date
    Mar 2006
    Location
    South Western, TN
    Posts
    44

    Default

    4 wheel drive switch/indicator if anyone needs one I have a brand new one left over from my AV....

Similar Threads

  1. Avalanche mpg [Expired Topic]
    By TrailLeadr in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 8
    Last: 09-27-2010, 12:12 PM
  2. set for avalanche rims for sale [Expired Topic]
    By 87burb in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 1
    Last: 02-03-2010, 07:06 PM
  3. '07 Avalanche [Expired Topic]
    By Steve-B in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 14
    Last: 12-11-2009, 12:19 PM
  4. General Tech Q&A [Expired topic]
    By pompiyer in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 4
    Last: 11-18-2009, 08:04 PM
  5. Throttle body spacer [Expired Topic]
    By thomsen05 in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 10
    Last: 10-11-2009, 11:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •