GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1

    Default Another fuel pump?

    I've got a '99 Burb with the 5.7L. It has died on me a couple of times the past few weeks. Running fine and then dies. If I wait a while, it will start back up. I'm thinking maybe the fuel pump is heating up? The pump has been replaced once about a year and a half ago with an AC Delco. New filter, but it hasn't been changed since.The first time this happened I had it towed home and after taking it off the tow truck, it started right up. The second time was a few days ago and fortunately, it died once I pulled in the drive way. Started looking on the forums and saw some posts about letting it cool off and try again and went out and sure enough it started back up, probably an hour later. Each time was after driving for about 45 minutes. Short trips less than that seem to be OK. If the filter is bad, could it put that much strain on the pump to cause it to heat up and fail. And if so, would you think the pump is damaged beyond reliability. I can slap on a new filter and check pressure. I guess if the pressure is good, the pump might be OK?
    Thanks

  2. #2

    Default

    It is possible for the fuel pump to be put under that much stress to cause it to crap out. If that is happening and the filter is only a year old, than I would be looking into your tank to see how much crap is in there. I would also start paying close attention to the condition of the gas stations that you're using.
    Scott

    ΜΟΛΩΝ ΛΑΒΕ

    '94 Chevy Suburban K1500
    3" exhaust w/ aero turbine non-baffled muffler
    CFM Technologies TB spacer
    CB w/ 44" whip antenna


  3. #3

    Default ANother fuel pump?

    Good point. I tend to get gas from Mobil, Sunoco, BP though, so I wouldn't expect that to be a problem but you never know really. I also put Techron in the tank every so often too because of the issue with the sending units on these GM pumps.

  4. #4

    Default Another fuel pump?

    Would a faulty fuel pump regulator cause a stall and no start condition? Is the only way to test the FPR with a pressure gauge? On the '99 350 I don't think I have easy access to it, do I? I'm trying to eliminate all the possibilities before taking the tank off. Thanks.

  5. #5
    Sr. Apprentice
    Join Date
    Dec 2008
    Location
    Findlay,Ohio
    Posts
    47

    Default

    I know you probably don`t want to think about dropping the tank again but check the electrical pin connector where it plugs in, this has been known to go bad before. Sometimes they make contact and work and sometimes they will expand and not make contact.

  6. #6

    Default

    Quote Originally Posted by Frankko View Post
    Would a faulty fuel pump regulator cause a stall and no start condition? Is the only way to test the FPR with a pressure gauge? On the '99 350 I don't think I have easy access to it, do I? I'm trying to eliminate all the possibilities before taking the tank off. Thanks.
    A fault FPR can cause a stall/not start condition. However, where your problem seems to be intermittent, I would lean more to the problem being something electrical.

    The only way I can think of the really know if the FPR (and the rest of the fuel delivery system) is working right is with a pressure gauge. It's also very easy, as the Schrader valve test port is readily accesible. Basic fuel pressure test would only take 5-10 minutes once you have the gauge. If you are trying to avoid getting a gauge, I would recommend you break down and get one -- especially if you are serious about diagnosing these things yourself. A pressure gauge isn't expensive: Harbor Freight sells (or at least used to sell) one that cost between $10 and $20, the gauge I have sells for around $40.

    Easy access to the FPR depends on how you define easy. In order to replace the FPR, you have to remove the upper intake manifold, and so it depends on if you consider that easy or not.

    Jim1958's suggestion to check the wiring is a good one, especially if the wiring harness at the pump wasn't replaced when the pump was replaced. It does seem to be pretty common for the harness to go bad over time.

    Another thing I would recommend doing would be to put a code reader on it and pull codes (including pending codes). Sometimes these kinds of problems will leave clues in the computer that can help determine why it stalls/won't start.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  7. #7

    Default Another fuel pump?

    Yeah, I've seen some posts on the forums talking about that. It seems odd that it would only fail after being driven for a certain amount of time. But, since its only happened a few times maybe I don't have a real repeatable scenario yet. I'm not sure if the harness and connector were replaced the last time because I had to have someone do the job. I'll be doing it this time and the Delphi pump I can get locally has the new harness included. Which brings me to another topic about which pump to use. I see a lot of people on this and some of the other forums say to definitely use factory pumps, but aren't these factory pumps the ones that keep failing and have the oh too long history of failing? I know some of the aftermarket stuff may be crap, but I'm beginning to think they all may be crap. I'll probably go with the Delphi since it comes from a local parts store I really like, but it is frustrating. Thanks...

  8. #8

    Default

    Along the electrical thought, you may want to check the fuel pump relay, as well. It's been my experience that it usually turns out to be the pump; but relays fail, too. Plus they're cheaper and easier to get to than the pump.

    Good luck,

    1999 Chevy K2500 Suburban 350
    K&N, reworked cai, Thrush cat-backs
    Vinyl, cranks, floor shift, and rear air!

  9. #9

    Default Another fuel pump?

    Does anybody know if you need a special fuel pressure test gauge for our trucks? I took a look at Harbor Freight and the one they show says it doesn't work with GM throttle body systems:
    http://www.harborfreight.com/cpi/cta...emnumber=92699 and they do show one more that looks to be more generic: http://www.harborfreight.com/cpi/cta...emnumber=93547
    I'm guessing I need one more like this at Autozone:
    http://www.autozone.com/R,3113840/st...ductDetail.htm
    I would think any gauge would work if you used the fuel rail, but...
    Thanks again.

  10. #10
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default

    I agree with the MrShorty and Jim1958. I have dropped so many tanks to do fuel pumps and it was just the wiring harness in the tank. That is why when you buy those fuel pumps some of them even come with a new harness to install. But through my experience if you do drop the tank, you might as well put a new pump in there, cause you never know when it is going to go bad on ya. For the FPR, I would think you would be having that problem consistantly, not just after a certain amount of time. I would aim for the pump and the harness. Good luck and keep us updated.

Page 1 of 3 123 LastLast

Similar Threads

  1. Is it my fuel pump
    By treysanatomy in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 02-06-2010, 03:10 PM
  2. Fuel Pump & FPR Didn't fix!HELP!!!!
    By tahoe freak in forum General Chevy & GM Tech Questions
    Replies: 8
    Last Post: 12-08-2008, 12:56 AM
  3. Twitching/vibrating fuel gauge - Not the fuel pump assembly.
    By Springthing in forum Audio, Video & Gadget Tech
    Replies: 3
    Last Post: 09-26-2008, 05:10 PM
  4. Fuel Gauge sender/fuel pump Together-seperate???
    By TahoeCrowe in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 09-05-2008, 02:55 PM
  5. New gal with fuel pump ???'s
    By ymisoqt in forum Member Introductions
    Replies: 9
    Last Post: 09-02-2008, 08:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •