GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default What should I do about these codes

    I just bought a 2005 GMC Sierra 1500 with the 5.3 liter and 31k miles. Yesterday I hauled my camper about 60 miles to the dealership that I bought it at for some service work. While I was accelerating up a hill, the check engine light came on and flashed 6 or so times. I let off the gas and it went off.

    When I finished dropping the camper off, I was pulling back out onto the road and the engine stumbled and the light came back on steady. From there on out, when I pulled up to a red light and stopped, it would almost die. It did fine on the highway though so I went on home. I went by Autozone and they scanned it pulling the P0131 and P0171 codes indicating a lean reading on Bank 1, Sensor 1. I don't want to overreact and change out the o2 sensor as it may not be that so any feedback from you guys would be great.

    We also have a 2004 Tahoe with the 5.3 liter and I have noticed that my Sierra does not seem to have as much power as the Tahoe but I assumed that had more to do with the 3.73 rearend in the Tahoe and the 3.42 in the Sierra. Don't know if this would indicate anything.

    Thanks for the help!

  2. #2

    Default

    Quote Originally Posted by hkinsland View Post
    I just bought a 2005 GMC Sierra 1500 with the 5.3 liter and 31k miles. Yesterday I hauled my camper about 60 miles to the dealership that I bought it at for some service work. While I was accelerating up a hill, the check engine light came on and flashed 6 or so times. I let off the gas and it went off.

    When I finished dropping the camper off, I was pulling back out onto the road and the engine stumbled and the light came back on steady. From there on out, when I pulled up to a red light and stopped, it would almost die. It did fine on the highway though so I went on home. I went by Autozone and they scanned it pulling the P0131 and P0171 codes indicating a lean reading on Bank 1, Sensor 1. I don't want to overreact and change out the o2 sensor as it may not be that so any feedback from you guys would be great.

    We also have a 2004 Tahoe with the 5.3 liter and I have noticed that my Sierra does not seem to have as much power as the Tahoe but I assumed that had more to do with the 3.73 rearend in the Tahoe and the 3.42 in the Sierra. Don't know if this would indicate anything.

    Thanks for the help!
    When ever you have an O2 code the very last thing you want to do is change the sensor. Something upstream is usually causing the problem. Vacuum leak, dirty injector or Airflow sensor. Reading the fuel trim on a scanner will really help pinpoint the problem.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    I'd run some Sea Foam through it first and drive it around a bit before considering changing out the O2 sensors. My wifes suburban was giving codes for the O2 sensor right after Christmas, ran sea foam through it, had her use a couple tanks of super (since the price was down again) and the light hasn' t come on again for that code again since.

    try that before anything else and see what happens,, you are talking $7.00 versus around $80.00+ each for the O2 sensors

Similar Threads

  1. Codes 42, 43, 44
    By clifton in forum GM Powertrain
    Replies: 2
    Last: 10-13-2009, 12:41 AM
  2. RPO codes
    By tankdg1 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 7
    Last: 09-12-2009, 01:50 PM
  3. codes
    By x1078p in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 3
    Last: 07-30-2009, 10:40 AM
  4. help have u and p codes what to do
    By johnpimentel72 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 06-30-2008, 08:32 AM
  5. GMC RPO Codes [Expired Topic]
    By Dr_Zero in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 03-14-2006, 07:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •